Mate 22.04 Constant Freezes on Wake

I have a Lenovo laptop with Intel i7 processor and nvidia GPU. I have been experiencing constant freezes since I installed it. Is anyone else experiencing this issue?

I used to experience hiccups on some computers like that many years ago. It always turned out to be the proprietary (closed source) nVidia driver.

To find out if that is the problem:

  1. uninstall the proprietary drivers.
  2. reboot and check if the problem is gone.

  1. If the problem is gone , it means that the nVidia driver is the culprit.
    In that case, either keep on using the nouveau-driver or (if you are a gamer or a CUDA user) try different driverversions with either the 6.xx series kernel or the 5.xx series kernel.

  2. If the problem is still cropping up, the problem is not in the nVidia driver
    you might have a failing RAM. Best to do a RAMtest (you'll find that in GRUB bootmenu or as a startmenuoption on the Live(USB) iso )


I have tried proprietary drivers and noveau. I even tested the memory and after 3 passes 0 errors. Any other ideas?

Hi, @xandermp :slight_smile:

Besides the good suggestions that @tkn (thom) has already given you in this topic, I've found the following "Ask Ubuntu" Question & Answer, from 2020, that seems relevant:

In that question, the user Sahit Berisha says that he was using Ubuntu 20.04 in a Lenovo Thinkpad T450s and that, every time after he woke the laptop from suspend mode, it froze for about 20-30 seconds and only then it let write the password for login.

That question has been answered, in that same web page, by the user "special", in "20.04 - After waking up from sleep Ubuntu freezes about 20-30 seconds - Ask Ubuntu" with the following reply:

"Had the same problem on a Thinkpad T440p with Ubuntu 20.04.2 TLS (64-bit).

Uninstalling fprintd fixed it (the fingerprint login didn't work very well for me anyway):

sudo apt remove fprintd

Sahit Berisha marked that question as solved / answered and wrote in a comment that the suggestion of removing "fprintd" also worked for him / her:

@xandermp: if you don't use fingerprint login, I think you can try that suggestion of removing the "fprintd" package. By the way, I've found more information about "fprintd" at the following web page:

I hope this helps :slight_smile: