Mate asking for Win password when no password

Would just like to know;
When connecting A Mate machine to a windows network, the Mate machine asks to input a password for the Win machine, even though the Win machine is not password protected…
Is it just a requirement from the Linux end that I have to add a password to the Win box?
I can see the Linux shares from Win, no problem, not asking for any password, am I missing something, or is this how it is


I just choose anonymous login and it seems to connect ok to my Win7 plex server. you do realise, its asking for the network Samba share password NOT the user login password dont you?
Check the shared folders on your windows pc, and make sure you allow guest login, and If you want to write to that folder, you’ll have to tick the read/write access as well as guest.

I am not offered the option of "Anonymous"
This is what i am offered, and thanks for clarifying, I was not sure if it was the Samba/Win pass it was asking for, is samba password my Linux logon, or do i set it up somewhere?
Also, I am not seeing an option under advanced sharing on Win to allow guest, I have everything shared using "Everyone", read only, not wanting write option allowed

I’ve found Windows File Sharing very fiddly to say the least. Check for any options in Windows’ advanced sharing options like “Password protected sharing”.

This can happen connecting on Windows too.

Steve, are you actually saying, go into user Accounts in Win and enable “Guest Account”?

Password Protected sharing is turned off in network & sharing on Win, both places

This may or may not work, but it’s worth a shot. Try adding the following to the /etc/samba/smb.conf file on your Linux machine.

security = user
map to guest = Bad User

Restart Samba after that, and see if it’s solved.

What will this actually achieve?

Have a great day… unless you’ve made other plans !

It’s supposed to map calls to a user account to the system’s guest user. Usually I’ve used that in a reverse scenario (Linux machine hosting a Samba share to Windows) but it may work in your environment. You could try it, and if it doesn’t work, remove the lines.

Ok, I’ll try it when I get home, thanks. The Win box sees the Linux shares no problem, tricky stuff!

Unfortunately, that’s typically the way it is. Windows generally won’t allow access to a network share as a user with no password, which is why the guest method I posted may work.