MATE Desktop 1.16 for Ubuntu MATE 16.04

Thanks @Wimpy for the update!

Call me stubborn, but I am already missing the GTK 2 look & feel of MATE, this shutdown dialogue isn't the same anymore: :confounded:

1 Like

Ran through the update procedure again today, including “adding” the ppa, which does show in software sources as there . . . and I tried “dist-upgrade” . . . shows “3 packages held back” . . . “mate-media-common mate-notification-daemon-common mate-power-manager-common.”

Same deal, MATE DE is “busted flat” . . . only DE left working is XFCE . . . sort of out of things left to try . . . .

Hi @lah7. I’ve been looking at that shutdown dialog for a different reason but 16.10’s GTK3+ is quite different looking than 16.04’s MATE 1.16. Here’s a direct compare but I should add this latest, too, as this theme has that same <—wide—> look.

1 Like

I also back ported a new version of mate-dock-applet

et al:

Spent a couple hours using synaptic to try to find a “solution” to the busted DE using different search terms to show various packages . . . seemed to be split packages, some remaining from 1.12 showing as installed and others from 1.16 showing as installed. The packages named “mate-desktop-environment” were not installed, so I kept trying to get it installed but kept getting errors . . . trying to get “mate-desktop-environment-core” to install brought back an error window with a bunch of “dependency problems” . . . mentioning caja and marco as "needed, but will not be installed . . . " ??? Synaptic can’t seem to find its way to getting MATE 1.16 to be operational . . . seems to be quite a “mess” even though “no broken packages” is showing as sit-rep . . . .

At one point I checked the tab for “early release in xenial” and that showed a bunch of upgrades . . . none of them were for “mate” . . . so I unchecked it. So far this upgrade is not working in PPC-land . . . MATE remains . . . gone.

Hi @non_space,

open Synaptic > Settings > Repositories and change your software download location then try updating again!.

See also:

That meta-package is not part of the default install.

~$ apt-cache policy mate-desktop-environment
  Installed: (none)
  Candidate: 1.16.0+1~xenial3.1
  Version table:
     1.16.0+1~xenial3.1 500
        500 xenial/main amd64 Packages
        500 xenial/main i386 Packages
     1.12.0+1 500
        500 xenial/universe amd64 Packages
        500 xenial/universe i386 Packages

@wolfman: Thanks for the suggestion, I’ll check it in a bit and report back on it.

@anon42388993: OK, thanks for the post; I was just reporting what I was encountering in the upgrade process, and trying to figure out why the MATE DE log in option was completely gone from the list of options. But, again I’m in PPC, and I don’t think what you are showing in your search is the repos for PPC??

Nope, I did not catch that in your first post. I’m on a standard 64bit install, so disregard please.

very easily done . . . : - ) Still haven’t had the time to boot the Powermac and try out Wolfman’s idea . . . back in a tad bit.


Tried this change, only two options “main server” or “united states” . . . it was on “main” so I switched it to “US” . . . and it did show “us.archives” in the update list . . . but it showed “0” across the board for upgrades, broken, and held backs . . . so, unless I didn’t get your suggested idea input correctly . . . the change didn’t seem to make any difference??? Perhaps I’ll try to set it back to main server??? I’ll take a breeze through your link to the Update Guide; nothing has been changed except for adding the ppa for “dev” . . . of which, like another ppa I added, only the “main” line is checked, the two “source code” lines are unchecked in the synaptic repos.

I see an “InRelease” phrase showing up in the console on update, so I believe the ppa has been included, etc . . . it just seems like there are some dependencies that aren’t being addressed in the PPC realm???

[edit a few minutes later]: Got the Software Boutique fixes showing in XFCE, and tried a few things, very quickly it said “Repair successful” . . . too fast to have actually done anything. Also I am getting a 404 error from a couple of “xenial/main/binary/powerpc/packages” . . . links . . . saying to “check my internet connection” . . . but, I’m typing this in XFCE 16.04 so connection is “OK” . . . .

Other interesting thing, in synaptic relaunch it showed “main server” again in download location, but in console it is still showing “us.archive”??? Anyway . . . seems like something isn’t working for PPC at the moment.]

Hi @non_space,

are you sure it isn't also showing "Other"?. :smiley:


Yep, very sure . . . it was kind of “funny” that the drop down menu wouldn’t just stay open, but quickly would disappear, had to quickly select the “US” line–but there was no “Other” option . . . just “Main” and “US” in my case.

I’m looking at this 404 error on the “powerpc Packages” as an aspect of the problem right now; I don’t know if there was some issue with my internet connection due to inclement weather, or whether it was on the server side the packages weren’t available . . . seems like a series of problems on this upgrade making it “difficult.” Anyway for the next half day or more, at work, Power Mac at home . . . so I can’t do experiments. But I can almost guarantee that there was no “Other” option to select . . . .

Hi @non_space,

have you tried the fixes in “Welcome”? (see the update guide again!. The first 3 pics!): :smiley:

I have noticed a slight glitch (random split second freeze) in mouse movement that was not present in 1.12.

2core/2G ram & no swap

Turns out to be browser related, switching over to FFesr took out just about all of the mouse glitch.


Mentioned in the previous post . . . XFCE doesn’t have “welcome” but it did have “Boutique” and I found those four tabs to do various tasks . . . and I clicked on each of them and they each said “successfully repaired” . . . but it happened so quickly that don’t think anything was actually done . . . . But, conversely, nothing was shown as a “problem.” Just like now, even though running through various update/upgrade and/or “-f install” . . . except for those 404 errors now . . . it shows “0 upgrades, 0 broken, 0 held back” . . . a tad “puzzling.”

I also have PPC update problems, after running through the MATE 1.16 upgrade procedure I now get a red bar on the login prompt after entering my password which says “Failed to start session” - any ideas welcome…

Warning to other PPC users this may bork your install - My friday night will be spent reinstalling as I figure it will be quicker in the long run…

No errors during the update to 1.16, all went without a hitch but on reboot its impossible to login “Failed to start session”. Will either try the update again right after install (in which case I will report back here) or just stay on the older version.


It’s lucky if your “older version” is still working, because indeed, it does appear that trying to upgrade to 1.16 “will ‘bork’ your PPC MATE session” . . . spent some more time yesterday trying to “fix” the install, and or “regress” back to MATE 1.14 . . . but my attempts to remove the “dev” ppa didn’t make any difference to the situation. I also tried to use synaptic to install “ubuntu-mate-desktop” . . . but it was “flagged” with the exclamation point and error provided was called “broken” . . . . I didn’t try to “force the package” as numerous dependency problems were showing.

The error in the PowerPC packages sources list continues to show up . . . however, in a Lubuntu 16.04 install on another computer, also PPC . . . I checked the sources list, very short list, ran the upgrades, no errors from the PPC side . . . . I tried to set my MATE source list to be similar to the Lubuntu Software Updater info . . . and tried the update/upgrade in the PowerMac . . . no luck . . . MATE remains busted. XFCE session is OK in spite of the 404 error in the update list.

I ended up reinstalling as guessed this would be just as quick as investigations. Will leave the 1.16 upgrade alone until/if it’s included in the main PPA (or 16.04.2?) and will not be adding additional PPAs again.