MATE Desktop 1.16 for Ubuntu MATE 16.04


#21

Hi Bill_MI, thanks for the clarification, my final confirmation is from my computer, I had desktop 1.14 and I upgraded to desktop 1.16, the question was about a new installation that I am going to make to a friend. regards…


#22

This is what I did yesterday; I installed UM 16.04.1, upgraded the system, rebooted and then installed mate 1.16. It was flawless.


#23

I also noticed that the Thunderbird icon in the dock applet now shows an overlay indicating the number of unread mails.
Is this new with 1.16 or has this been there all along and I somehow always missed it?


#24

I followed the suggested commands for my U-MATE 16.04 PPC edition, I saw the terminal or apt installing “MATE 1.16” items but, on reboot the MATE session was gone–the log in for an old GNOME DE was “default” but nothing to log into. So I logged into XFCE and then I tried running “apt-get dist-upgrade” and same issue after installing a number of other packages not installed by apt. Then I ran “sudo apt-get -f install” and that showed a few other packages to install . . . then I shut the computer down . . . on reboot, same problem . . . MATE is “gone” in PPC land . . . . Only “problem” I recall is there was something about “keyring not found”??? but, it continued on with the “full-upgrade” . . . that end happened a little too fast to know if that was an “issue.” It ran through the 200MB full upgrade process, and the cursor “returned” w/o reporting any other errors–that was a couple hours ago–I saw in the thread here that wimpy said the “ppa was down” . . . not sure if I ran my process then or well after . . . ??

A little surprising in that generally the U-MATE upgrades have been pretty smooth–don’t know if this is part of the “PPC is persona non grata” problem??

Any thoughts, happy to try them out . . . .

n_s


#25

Another, unfortunately less pleasant observation about the dock:


The pop-up looks a bit off (and that’s with pretty much every theme).


#26

I’ve done at least 3 fresh system installs the last couple of days. To be honest I don’t remember what triggered that. The first time around I installed Ubuntu Gnome because I have been needing some desktop connectivity to my Google account. Contrary to the latest claims about Gnomes Google connectivity it really doesn’t work very well. On top of that you are still dealing with their poor excuse of a file manager Nautilus.

Round 2 I installed Ubuntu Mate 16.10 but there were graphics issues that were just annoying me and no way to get them to correct themselves. My laptop has Intel i7, 12gb ram, and nvidia m-840 graphics. open source or proprietary graphics drivers made no difference, neither did the compositor being used. So I decided to reinstall 16.04.1 which is back to running fine after upgrading Mate to 1.16.1 installing proprietary drivers and running a full- upgrade.

I’m going to sit back and see how things transpire for awhile with the current LTR. At the end of the day when I have to start spending more than a normal amount of time messing with the system to correct issues to make it run properly I will go back to running Debian Testing non-free. That generally takes a couple of hours to install and set up, but after that is tends to be a no hassle system that semi rolls and provides a good couple of years service until I mess around with it and need to re-install.


#27

Thanks @Wimpy for the update!

Call me stubborn, but I am already missing the GTK 2 look & feel of MATE, this shutdown dialogue isn’t the same anymore: :confounded:


#28

Ran through the update procedure again today, including “adding” the ppa, which does show in software sources as there . . . and I tried “dist-upgrade” . . . shows “3 packages held back” . . . “mate-media-common mate-notification-daemon-common mate-power-manager-common.”

Same deal, MATE DE is “busted flat” . . . only DE left working is XFCE . . . sort of out of things left to try . . . .


#29

Hi @lah7. I’ve been looking at that shutdown dialog for a different reason but 16.10’s GTK3+ is quite different looking than 16.04’s MATE 1.16. Here’s a direct compare but I should add this latest, too, as this theme has that same <—wide—> look.


#31

I also back ported a new version of mate-dock-applet


#32

et al:

Spent a couple hours using synaptic to try to find a “solution” to the busted DE using different search terms to show various packages . . . seemed to be split packages, some remaining from 1.12 showing as installed and others from 1.16 showing as installed. The packages named “mate-desktop-environment” were not installed, so I kept trying to get it installed but kept getting errors . . . trying to get “mate-desktop-environment-core” to install brought back an error window with a bunch of “dependency problems” . . . mentioning caja and marco as "needed, but will not be installed . . . " ??? Synaptic can’t seem to find its way to getting MATE 1.16 to be operational . . . seems to be quite a “mess” even though “no broken packages” is showing as sit-rep . . . .

At one point I checked the tab for “early release in xenial” and that showed a bunch of upgrades . . . none of them were for “mate” . . . so I unchecked it. So far this upgrade is not working in PPC-land . . . MATE remains . . . gone.


#33

Hi @non_space,

open Synaptic > Settings > Repositories and change your software download location then try updating again!.

See also:


#34

That meta-package is not part of the default install.

~$ apt-cache policy mate-desktop-environment
mate-desktop-environment:
  Installed: (none)
  Candidate: 1.16.0+1~xenial3.1
  Version table:
     1.16.0+1~xenial3.1 500
        500 http://ppa.launchpad.net/ubuntu-mate-dev/xenial-mate/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/ubuntu-mate-dev/xenial-mate/ubuntu xenial/main i386 Packages
     1.12.0+1 500
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://us.archive.ubuntu.com/ubuntu xenial/universe i386 Packages

#35

@wolfman: Thanks for the suggestion, I’ll check it in a bit and report back on it.

@v3xx: OK, thanks for the post; I was just reporting what I was encountering in the upgrade process, and trying to figure out why the MATE DE log in option was completely gone from the list of options. But, again I’m in PPC, and I don’t think what you are showing in your search is the repos for PPC??


#36

Nope, I did not catch that in your first post. I’m on a standard 64bit install, so disregard please.


#37

very easily done . . . : - ) Still haven’t had the time to boot the Powermac and try out Wolfman’s idea . . . back in a tad bit.


#38

@wolfman:

Tried this change, only two options “main server” or “united states” . . . it was on “main” so I switched it to “US” . . . and it did show “us.archives” in the update list . . . but it showed “0” across the board for upgrades, broken, and held backs . . . so, unless I didn’t get your suggested idea input correctly . . . the change didn’t seem to make any difference??? Perhaps I’ll try to set it back to main server??? I’ll take a breeze through your link to the Update Guide; nothing has been changed except for adding the ppa for “dev” . . . of which, like another ppa I added, only the “main” line is checked, the two “source code” lines are unchecked in the synaptic repos.

I see an “InRelease” phrase showing up in the console on update, so I believe the ppa has been included, etc . . . it just seems like there are some dependencies that aren’t being addressed in the PPC realm???

[edit a few minutes later]: Got the Software Boutique fixes showing in XFCE, and tried a few things, very quickly it said “Repair successful” . . . too fast to have actually done anything. Also I am getting a 404 error from a couple of “xenial/main/binary/powerpc/packages” . . . links . . . saying to “check my internet connection” . . . but, I’m typing this in XFCE 16.04 so connection is “OK” . . . .

Other interesting thing, in synaptic relaunch it showed “main server” again in download location, but in console it is still showing “us.archive”??? Anyway . . . seems like something isn’t working for PPC at the moment.]


#39

Hi @non_space,

are you sure it isn’t also showing “Other”?. :smiley:


#40

@wolfman:

Yep, very sure . . . it was kind of “funny” that the drop down menu wouldn’t just stay open, but quickly would disappear, had to quickly select the “US” line–but there was no “Other” option . . . just “Main” and “US” in my case.

I’m looking at this 404 error on the “powerpc Packages” as an aspect of the problem right now; I don’t know if there was some issue with my internet connection due to inclement weather, or whether it was on the server side the packages weren’t available . . . seems like a series of problems on this upgrade making it “difficult.” Anyway for the next half day or more, at work, Power Mac at home . . . so I can’t do experiments. But I can almost guarantee that there was no “Other” option to select . . . .


#41

Hi @non_space,

have you tried the fixes in “Welcome”? (see the update guide again!. The first 3 pics!): :smiley: