MATE Desktop 1.16 for Ubuntu MATE 16.04


#42

I have noticed a slight glitch (random split second freeze) in mouse movement that was not present in 1.12.

2core/2G ram & no swap

Edit:
Turns out to be browser related, switching over to FFesr took out just about all of the mouse glitch.


#43

@wolfman:

Mentioned in the previous post . . . XFCE doesn’t have “welcome” but it did have “Boutique” and I found those four tabs to do various tasks . . . and I clicked on each of them and they each said “successfully repaired” . . . but it happened so quickly that don’t think anything was actually done . . . . But, conversely, nothing was shown as a “problem.” Just like now, even though running through various update/upgrade and/or “-f install” . . . except for those 404 errors now . . . it shows “0 upgrades, 0 broken, 0 held back” . . . a tad “puzzling.”


#44

I also have PPC update problems, after running through the MATE 1.16 upgrade procedure I now get a red bar on the login prompt after entering my password which says “Failed to start session” - any ideas welcome…


#45

Warning to other PPC users this may bork your install - My friday night will be spent reinstalling as I figure it will be quicker in the long run…

No errors during the update to 1.16, all went without a hitch but on reboot its impossible to login “Failed to start session”. Will either try the update again right after install (in which case I will report back here) or just stay on the older version.


#46

@topbanana:

It’s lucky if your “older version” is still working, because indeed, it does appear that trying to upgrade to 1.16 “will ‘bork’ your PPC MATE session” . . . spent some more time yesterday trying to “fix” the install, and or “regress” back to MATE 1.14 . . . but my attempts to remove the “dev” ppa didn’t make any difference to the situation. I also tried to use synaptic to install “ubuntu-mate-desktop” . . . but it was “flagged” with the exclamation point and error provided was called “broken” . . . . I didn’t try to “force the package” as numerous dependency problems were showing.

The error in the PowerPC packages sources list continues to show up . . . however, in a Lubuntu 16.04 install on another computer, also PPC . . . I checked the sources list, very short list, ran the upgrades, no errors from the PPC side . . . . I tried to set my MATE source list to be similar to the Lubuntu Software Updater info . . . and tried the update/upgrade in the PowerMac . . . no luck . . . MATE remains busted. XFCE session is OK in spite of the 404 error in the update list.


#47

I ended up reinstalling as guessed this would be just as quick as investigations. Will leave the 1.16 upgrade alone until/if it’s included in the main PPA (or 16.04.2?) and will not be adding additional PPAs again.


#48

I used ppa-purge to roll back to 1.12, since there were changes I didn’t quite like and a couple of minor regressions. Pity I couldn’t go back to 1.14. :frowning:


#49

@lah7:

Is this in reference to a PPC install? Or regular ???

@et al:

I replied to the topbanana post via email . . . doesn’t seem to have made it into the thread?

n_s


#50

No, I’m on a regular PC. I was just making a “just throwing it out there” sort of comment.

The upgrade did work fine, but there were a few small things that was enough for me to downgrade for now:

That won’t happen, since 16.04 is a LTS and only accepts bug fixes for stability - this PPA was to provide a new version kindly backported by @Wimpy for users on 16.04. It could be possible for someone to package up MATE 1.14 and provide packages / a PPA for it.

The logs don’t tell me anything about you sending in a reply. :thinking: Try again, or post here?


#51

@lah7:

Cool, thanks for the reply . . . interesting that you couldn’t drop back to 1.14 in the downgrade . . .??

I think I have U-MATE “regular” installed on a MacPro based on 16.04 . . . possibly I checked that version of MATE and I believe that it was 1.16?? Or it could have been the Gecko MATE system installed on same computer ??? One of them had 1.16 as the de facto DE . . . . My problem child of course is the PPC system, machine running generally fine . . . lagging as far as resources for dealing with the web, but for most other tasks, just fine.

My email back to TopBan was referring to the later options for PPC in U-MATE that are possible choices, rather than Top’s choice for re-install . . . 16.10 and a beta 17.04 that I was considering, since to get back to the MATE DE would probably mean having to do a nuke/pave . . . those would likely be the last options for PPC users . . . although I generally go with LTS versions, which might mean a re-install of xenial MATE.

PPC is not getting a lot of “love” from the upstreamers these days . . .


#52

This was fixed in today’s update.


#53

devs:

I ran through this upgrade today on my Mac Pro U-MATE 16.04 install and all seemed to go well . . . rebooted back into the new MATE 1.16 . . . . Other than a “momentary” odd moment where the FF toolbar where the three buttons upper right extended passed the right side of the window . . . that was “handled” by quiting the app and re-opening . . . the edge of the toolbar now marks the edge of the rest of the window . . . .

No noticeable differences yet between the older MATE 1.12?? and the newer version . . . ??? Guess it’s all “under the hood”???

n_s


#54

You’re welcome to investigate the changes since 1.12 by checking out the successive release announcement since that release.
Here’s the 1.14-1.16 release notes: http://mate-desktop.org/blog/2016-09-21-mate-1-16-released/


#55

Great, works perfect. Thanks!
ABTW Zeitgeist (engine, daemon, lib) and Synapse launcher are great tools and help for my workflow.


#56

Thanks for the post, yes, the list looks substantial . . . but still “subtle” in the GUI from what was “there” before . . . visually speaking . . . seat of the pants . . . . Haven’t had a whole lot of time to spend with it yet; but overall my choice for DE’s is MATE in the linux distro realm . . . in the “bang for the buck” subjective scale.

n_s


#57

Hi,
This is good to read ! Thank you very much.
Just a question, in regard of going to LTS, how stable is this ppa for everyday computer ?


#58

It has been very stable, at least for me. I’ve run it since it came available (January 14th) on my main work computer (Ubuntu MATE 16.04.2 LTS). Approx. 10 hours/day hard work with multiple apps open so it really does get used - not just sit idling.


#59

thank you samuvuo !!! so let’s try it first in VM !! :sunglasses:


#60