MATE for Gaming?

Hi, wats the craic !

I’ve been using MATE for a while now on my Samsung RV515 laptop.
It does nearly everything i want it to do apart from play old games.
I had got my hands on the Medal of Honor war chest and was looking forward to playing it, i installed all the repository’s needed ( wine and stuff ).
First issue was the MOHAA launcher wouldn’t start the game because there is no opengl on system so i do a search and see it i need the AMD driver.
I download that and run the Script it does most of the install but then the terminal just closes with no error, i was able to see on the terminal that it was and issue with the Kernal not matching with the driver stack.
So now i am at the point i have just installed the 4.12 Kernal but am now stuck at ( How to apply the 3 patches that need to be installed after the Kernal ) I have looked for the answer but cant seem to find one that i can understand.
Is there no easy way to install patches ?
Is there an easier way to set up MATE for Gaming ?

I am not looking to play any new games on the laptop, just want to play old classics as the laptop cant handle to much.

Any help would be great.

The desktop environment shouldn’t have anything to do with the gaming experience, it should just work just fine on MATE. I assume you use Ubuntu MATE but what kind of version do you use, 16.04, 17.04 or anything else? What graphic card do you have?

‘Additional drivers’ usually can install proprietary drivers for your graphic card if you want to use that. You can do that through the software-properties-gtk application. But if you run 16.04 or later the proprietary AMD drivers have been deprecated.

Here are some pages about AMD-drivers for Ubuntu:

1 Like

Thanx for the reply
My Graphics are integrated in the APU
( Advanced Micro Devices, Inc. [AMD/ATI] Seymour [Radeon HD 6400M/7400M Series] [1002:6760] )

And my Linux version is 16.04.3 LTS (Xenial Xerus).

Straight out of the box MATE wouldn’t run any Windows games until i installed wine, then i was able to install and play COD4 but anything else i try just wont work. Its getting to the point were i might have to just do a fresh install maybe.


I’m using UM 16.04 for gaming for around six months now on my lenovo Y580 (opensource drivers 381.22 for geforce 660m) with Compton (window manager). I’ve been using steam and GOG native ports, Play on Linux for Diablo 3 and Path of Exile, EVE online (using port made by one of the devs). I am simply amazed by this setup and I had absolutely no problems whatsoever.

The titles I tried so far:
Witcher 2
Diablo 3
Path of Exile
EVE Online
Age of Wonders 3
Divinity Original Sin EE
This war of mine
Shadow Tactics:Blades of Shogun
Total War: SHOGUN 2
Total War: Warhammer

All working and looking great, losing maybe few FPS’es to a windows counterpart on this setup.
I believe clean start is a nice idea, but I’m quite a beginner when it comes to linux. I wanted to let you know that it is totally possible. I read somewhere however that it is less complicated with nvidia cards than with AMD.

Good luck man, hope you will be able to solve this.

I will have to try a fresh install then i recken. It’s the GOG games im trying to run, i got the Medal of honor war chest from GOG but no joy.

Have you tried Play on Linux? I've checked the available game list and there is a ready install of it with GOG version.

with play on linux it is very simple, it installs best wine version and some essential components for the game to work as good as possible.

Just tried that there now and !

Gonna try another game and see.

Well it’s above my linux skills so maybe someone else will help you.

Do you have mesa-utils installed?

sudo apt install mesa-utils

I do indeed, just ran that command and it says i have the latest.
mesa-utils is already the newest version (8.3.0-1).

Really dont understand whats happening, i tried deus ex last night aswell but playonlinux crashes witch a wine error.
All a man whats to do is have a nostalgia trip.

I am at a loss as to what i can do, thought i had everything installed that i needed but something isn’t right somewhere.

You could try to reinstall the open source drivers:

sudo apt install --reinstall xserver-xorg-video-ati libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core xserver-xorg-video-radeon

You might need to reboot the system as well.


I did that command and it seemed to install it alright, done a reboot and the laptop restarted to the login screen but i had no mouse or keyboard controll at all and the text curser on the password box looked like it had froze. So i done a hard reset and still the same thing, no mouse or keyboard.

I then got a bit annoyed and decided to just to a reinstall, so here i am again with a new install of mate and putting on the stuff i need like play on linux.

After the fresh install of MATE i installed playonlinux and then done a software update and rebooted. I then installed Medal of honor and it installs just fine but i get the same error in launcher as above ?
What is going on here.

I’m sorry, but I’m no expert in this area and I’m starting to get out of ideas. I don’t have an AMD card myself anymore so I can’t troubleshoot it myself. The only thing I’ve found now is that you are not alone, more people are having issues with this game and to aslo to get opengl to work:

For some people it has worked when they reinstalled the mesa-packages, but you’ve already tried that:
sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Have you install the “Wine Development Builds” available under Games in the Software Boutique-application?
ubuntu-mate-welcome -b

There is no “Wine Development Builds” in the software Boutique or Ubuntu software centre

Hmm. There is in my Software Boutique. Maybe you need to click the the Subscribe or “Receive Welcome updates” at the first screen of the Welcome application to get it.