MATE -MENU is not in panel


After unplanned shutdown of my PC the advanced MATE Menu is not on the panel any more (I'm using redmond styled panel) .
I was trying to recover it by:

  • mate-panel --reset
  • sudo apt-get install mate-core mate-desktop-environment mate-notification-daemon
  • sudo apt-get install --reinstall mate-core mate-desktop-environment mate-desktop-environment-extras

But without success. ...

When I tried to run it by hand I got this replay:

$ mate-menu
bash: /usr/bin/mate-menu: /usr/bin/python2: bad interpreter: No such file or directory

I even reinstall python with :
sudo apt install python --reinstall

All without luck. How to get it back?



This is the situation in the left corner...ATM

Hi @firmwarebug,

please, make sure your system is upgraded and broken packages are fixed since unplanned shutdown could interrupt some upgrade process (e.g. if you have automatic updates enabled). You also may want to tell which version of Ubuntu MATE you are using.

Normally, resetting your panel fixes such a problem. Since this does not work you may try the following:

  • Change your panel layout in MATE Tweak. Try something else and return to Redmond. This shall effectively reset your panel. Note all changes you did to your panel will be invalidated.
  • Try to unlock other applets from your panel and move them. Maybe due to some glitch they overlap your menu.
  • Try to add Advanced MATE Menu to your panel manually through panel context menu.

Good luck!


There is no broken packages in the system:

I' m using LTS Ubuntu Mate:

I have also tried to change panel layout, add remove Advanced Mate Menu as suggested, but with no success .
I think that package or config file (do not know which...) is somehow broken since I even can't start it from console.

The error is following:
:~$ mate-menu
bash: /usr/bin/mate-menu: /usr/bin/python2: bad interpreter: No such file or directory


Hi @firmwarebug,

regardless of your menu problem, the error message you are getting is quite disturbing. Both /usr/bin/python and /usr/bin/python2 shall be symlinks to /usr/bin/python2.7 in 18.04. Are you able to run python 2 interpreter via /usr/bin/python2 command in terminal? If these links are broken, fix them first.



Ironfoot Thank you !

I checked if python and python2 are present:

$ python
Python 2.7.17 (default, Nov 7 2019, 10:07:09)
[GCC 7.4.0] on linux2
Type "help", "copyright", "credits" or "license" for more information.

$ python2

Command 'python2' not found, but can be installed with:

apt install python-minimal
Please ask your administrator.

So I reinstall package :

sudo apt install python-minimal --reinstall
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/28,1 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 386775 files and directories currently installed.)
Preparing to unpack .../python-minimal_2.7.15~rc1-1_amd64.deb ...
Unpacking python-minimal (2.7.15~rc1-1) over (2.7.15~rc1-1) ...
Setting up python-minimal (2.7.15~rc1-1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

And then I run mate -menu form console to get menu back:

image :smiley:



1 Like