Mate Panel Always Moves My Applets Around

I am on Ubuntu 18.04.3 LTS with MATE 1.20.1.

Not quite sure, but I think this was an older Ubuntu system that got upgraded and MATE desktop environment installed afterwards.

My problem is that the mate panel always is moving around my applets. I would like to have the application indicator applet on the right side, but it is always moved to the center on new login. Also, all applets are pushed together, so that there aren't any spaces between them. Only the weather and clock applet remains on the right side.

Is there anything that I can do to prevent this?
This doesn't happen on my Linux Mint MATE system (which is older though) and it doesn't happen on another system where Ubuntu MATE was installed from scratch (which is newer though).

I know, it is always difficult to debug systems with an upgrade history. But installations from scratch cost much more time, especially on systems that were set up with lots of "special features".

Thanks in advance for any help!

Try adding the spacer applet

I found a vertical separator line - is this what you meant? I added it and will try it out.

After you rearrange your panel, you can lock it with that command:
gsettings set org.mate.panel locked-down true

gsettings set org.mate.panel locked-down false

I suggest you create icons in Menu with that commands.

The separator line didn't helped.

I tried "gsettings set org.mate.panel locked-down true" now, but it seems that is locks the items for interactive modification. I don't think this will help, as it is some kind of automatic rearrangement that takes place here.

Unfortunately I cannot logout/restart currently to test it...

Sorry Philippe, as expected the lock down of the mate panel didn't prevent the panel of shuffling the items at next logon. It is just a protection to the user to not accidently move items around...

This is a bit late but I find a fix for this:

As desktop user: pkill mate-panel

This kills the running instance which is immediatly replaced by a new instance that has all my applets in the position I had put them in.

I have to report, that the issue went away for me.
Catastrophically, I cannot remember when and why...

Maybe it was solved by a system update/upgrade.

Still happening to me. I have to kill the panel after every system start.

Note that this happens only with the command applet -- which has a couple of complaints for the log.