Mate Panel, Multi monitors, Display resolution


This is one of the little annoyance that avoid me maybe fully go through Ubuntu Mate.
At work as i am not using computers under MS Windows i always bring my own laptop and use VGA connection to connect to 1900x1200 screens resolutions (maybe 1900 x 1080 not sure)
Screens are working ok and i set up those as primary monitors and turn off the laptop’s screen.
With any DE (Gnome / kde Plasma / Unity) all the setup are just fine, same as i configured on the laptop.
With Mate and i’ll say unfortunately, i have to manually move all the applet i put in panel to get back to my original settings, to make working those panels in the same way as they appear (proportionally) on my laptop’s screen. The resolution is fine but the searching tool, date, time for instance are not in the place they should be.
Is there any way to get those being in the right place ?
As always, i apologize for my non-fluently English :innocent:

You could save your panel layout via Mate Tweak then when this happens you just have to reload the layout from Mate Tweak.

Hi ivCHo !
I have tried already without succeed… I works if i change the custom in Cupertino or any others proposed … but not if i go to my settings
Thanks anyway

Try using the auto-correct feature of your monitor (not your laptop monitor). i had the same problem with Ubuntu 14.04. The auto correct button are probably located on the sides of your monitor or underside of it. If you have the manual of the monitor look for where the buttons are located. Hope this helps.

Thank you ! I will try it tomorrow at work !!
I let you know about it.

I Tried with one monitor. It looks like if MATE panel’s elements are all “locked”, i can found back my settings.
In case, i just have to re-configure once > plug out and plug in VGA > settings are there in the place they should.
Those days i will test on another problematic monitor and let you know

It doesn't make the trick ....
reload a saved panel layout and making sure panel's elements are locked, actually seems to work !
I will try again later and see what happen.
thanks anyway !

Looks like if i custom panels from those monitors set as default when connecting my laptop, panels then record the properly layout. Back from vacations, connecting laptop, every thing looks in place …

So this happens when connecting to a monitor with higher resolution than the laptop screen has? And as I understand, the applets that stay in place are “locked”, which is shown in the right-click menu.

Yes it is

And now as i set those from the higher monitor resolution, it seems to be ok. I have same settings on both screen ( i turn off the default one, from laptop.
Thanks ...

I don’t get it in wath mode do you connect the second monitor ? (extended monitor , duplicate screen,xinerama) . If it is xinerama (whole panel extends on the second monitor) it is ok to bug with diffirent monitor resolutions since it makes all monitors 1 big screen. Extended monitor does not have any panels on it and have to be created manually (if possible , can’t test this couse nvidia-drivers don’t let me get to extended mode). Well duplicate screen is self explanatory .

One thing you can do is to dump dconf database before and after you fixed thair positions like
dconf dump /org/mate/panel/objects > before_screen.dconf
after you configure it for screen
dconf dump /org/mate/panel/objects > after_screen.dconf

Then you have files with positions of objects on the panel.
you can load them in back to dconf with
dconf load /org/mate/panel/objects < [name].dconf

And since mate-panel does not watch for gsettings changes
you have to restart the panel like :

mate-panel --replace &!

mate-panel --replace &

Yes, this had been fixed for the locked applets some time ago. They're moved as needed when switching to a lower resolution.
For switching to a higher resolution, can you try unlocking some applets (e.g. the rightmost ones) before the switch and see if they're moved to the right? This is only for an experiment - it's better to lock them after the switch again.

From VGA link.
I Right now seems to work, i keep your information in case.
I will take a look to dconf if needed
Thanks !

I 'll try !

Finally, i still have the “issue”. I have two monitors to connect to, each in one class room that i m working in. It looks like if i set up from one monitor, then unplug and connect to the second one in another place, applets are not set as i did before.
Not a big dill, but a bit boring to put them back. This is definitely the only inconvenient issue i noticed …
if you have any idea …

This seems to work !

Using Dconf-Editor go to > org-> mate-> panel-> general-> locked down -> true
i used some monitors without encountered the problem again.
I let you know