Mate settings daemon closed unexpectedly

I recently bought a new graphics card. It wouldn’t work with my system until I updated the motherboard BIOS - now the card works fine.

BUT ever since then I’ve been having “mate settings daemon closed unexpectedly” problems, and my settings don’t get set!

I even tried a fresh install of 15.10, but that didn’t help - the problem still happens when running a live session straight from a USB stick!

UM has become my fave distro ever, but it looks as if i’ll have to install something else, as I have lots of uni coursework to do.

I’m hoping there’s a BIOS setting that I can change, and go back to UM.

Any suggestions?

mobo: MSI P67A-GD53
gpu: AMD RD 380

When you updated the BIOS, have you tried to reset the BIOS settings too? Some will give an option to "Load fail safe defaults" or "Load optimised settings".

Equally, try running mate-settings-daemon from the terminal, to see if you can pick up any verbose error details on why it's crashing in the first place:

mate-settings-daemon --replace

Hi, thanks for your help,

i’m typing this in a live session and the output from your suggested command is:

**
MateDesktop:ERROR:mate-rr-config.c:661:mate_rr_config_load_current: assertion failed: (mate_rr_config_match (config, config))
Aborted (core dumped)

don’t know if that’s any help…

I think this might be a problem with monitor config . Have you tried changing the display settings after you changed the graphics card ? have you tried resetting mate-settings-daemon settings in dconf ? (sudo dconf --reset /org/mate/mate-settings-daemon)

I think @IvCHo is right, the graphics card or monitor is causing a problem with mate-settings-daemon. Concluded by this post from a quick search based on that error output. Since this fails to start, settings cannot be set.

The open source drivers (the default) could be the culprit here. Have you installed AMD’s proprietary drivers? (Word of warning: I’m not sure if an early bug is still present in 15.10 that prevents the system from booting with AMD’s drivers)

It seems to be a bug with MATE 1.10.2 - which Ubuntu MATE 15.10 uses. If need be, you could try Ubuntu MATE 15.04 or 14.04 LTS.

1 Like

thanks for your help both of you,

so it’s the gfx card and not the bios…

the problem occurs with the open-source drivers, which is why i’m also affected in live session. didn’t try the proprietary ones.

i may try UM 15.04 if my new distro doesn’t stick.

thanks again.

1 Like

I experienced all kinds of AMD related graphics problems with UM 15. Since going back to 14.04LTS all is well again.

So, I will be sitting this one out on UM 14.04 till the next LTS