Mate Terminal not available in "Preferred Applications"

under "Control Center -> Preferred Applications -> System -> Terminal Emulator" there is no option for Mate Terminal.

I know it was there once, so i guess it is a config problem...

I tried to "--reinstall" Mate Terminal to no avail.

To be precise, is this what you did?

~# apt-get install --reinstall mate-terminal

Was there an error message? What version are you using?

yes, but i also added mate-terminal-common to the command.

there was no error, everything looked as expected.
I am on the newest Ubuntu-mate 20.10, everything up-to-date.

what i just noticed is that there is also no option of the Calculator available... weird

I am on 18.04 LTS, so perhaps someone on a newer version will be able to help more.

since no one answered i presume its not easy to fix?

i know there was a command to create this link on the console, does someone at least know that one?

@TimeWaster, can you post a screenshot of that? I don't have 20.10. I've 20.04 and 21.04 and on both mate-terminal is listed under 'Terminal Emulator'. So is, calculator.

Anyways, try following and see if it helps.

sudo update-alternatives --config x-terminal-emulator

This will display all available terminals and you can choose mate-terminal to be default.

1 Like

so the problem is i cannot take a screenshot of the dropdown opened since it blocks all keyboard inputs for some weird reason (window manager i presume), but i can show you this:

i tried the command you posted but interestingly it lists mate-terminal twice, but both do not work (it does not change the behaviour of Caja for some reason, maybe i need to restart):

For this, you can set time before the application takes screenshot.
Screenshot at 2021-04-14 06-59-17

Like so,
Screenshot at 2021-04-14 06-59-53

Well, if update-alternatives didn't work, you could try one more thing. Check,

gsettings get org.mate.applications-terminal exec

and if it is other than 'mate-terminal', set it to mate-terminal as below.

gsettings set org.mate.applications-terminal exec 'mate-terminal'


yes, that worked, thank you very much!

still weird that the entries are missing in the GUI, though.

1 Like