Mate will not launch some programs

Ubuntu 18.04 with current updates: For several months, I had used ClipIt as my go to clipboard manager with Mate 1.22.2. Then one day, it behaved like it launched from the Action Bar, but didn't. Or if it did, it wasn't visible. I'd click on it 6-7 times and the icon would expand out like normal, but the program would never launch. Launching it from the App menu was the same. Could not find the symptoms or the issue anywhere online. Finally gave up and uninstalled the app.

Then installed (using Software Manager) CopyQ. Same problem. It acts like it's launching, but it never shows up on the screen.

Anyone have a clue of what's going on? I'm no expert so please walk me though a test if you will.


Welcome to Ubuntu MATE community!
Thank you for your interest.

Then lets analyze the problems:

Do you have ClipIt icon in tray on login?
Do you have ClipIt and CopyQ icons ( clipit-copyq ) in tray on their launch?

Did you tried to run them from terminal by clipit -h and copyq -v ?

How did you installed ClipIt and CopyQ? Please add output of

which clipit
which copyq

apt-cache policy $(dpkg -S $(which clipit))
apt-cache policy $(dpkg -S $(which copyq))

grep -i clipit ~/.xsession-errors
grep -i copyq ~/.xsession-errors

I did have Clipit in the tray on login, which I call the Action Bar if I understand your 'Tray' reference. It's the bar at the top of the screen that has quick launch icons for my favorites. Like browers and the like. But as I said, I uninstalled it using Software Manager. And reinstalled it, then uninstalled it. Several times over the weeks. Finally gave up and installed CopyQ, using Software Manager.

I do have the CopyQ icon in the action bar as you show above. It will not launch.

Start of requested outputs------------------------------------------------------

copyq -v
CopyQ Clipboard Manager v3.2.0 ([email protected])
Built with: Qt 5.9.3, LibQxt 0.7.0

which copyq

apt-cache policy $(dpkg -S $(which copyq))
  Installed: 3.2.0-1
  Candidate: 3.2.0-1
  Version table:
 *** 3.2.0-1 500
        500 bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
N: Unable to locate package /usr/bin/copyq

grep -i copyq ~/.xsession-errors
Retuns NULL

End of requested outputs--------------------------------------------------

I just discovered in Term that when I press up arrow, it doesn't show me any recent C&P that I've done today like it usually does. Not sure if that's part of the Copy issue or not.

If I try to run CopyQ from Term:

 copyq -v
CopyQ Clipboard Manager v3.2.0 ([email protected])
Built with: Qt 5.9.3, LibQxt 0.7.0

That's it, just that two line output, nothing on screen.

May be related to the issue. You may have some problems with permissions.

All files in the home folder are usually owned by your user.
To reassign all objects to your user you can use exact command as it written below:

sudo chown -R $USER:$USER ~/

(do not change $USER:$USER part of the command, the substitution with actual user name will be done automatically!)

And then reboot.

Sadly, that chown command didn't seem to make a difference.

Hi guys,
Maybe something missing in env, please do :

killall copyq
export DISPLAY=:0 

and give it a try again :slight_smile:

Can you also insure that there is no voodo in the screen config in Display app :


Like a second monitor or something.

More, you can also remove copyq user data from the home profile (or rename them _old) to start again with original copyq config :

rename or delete :

I hope it helps :slight_smile: Good luck !

You can also try this to dig inside the problem :

  • From copyq status icon, try to open settings (tell us if its opening)

  • Once there : set up some different shortcuts for this 2 commands :

  • Try to bring copyq main window with the new shortcut (to see if it will open)

  • copy some html decorated data (the ubuntu-mate community header will be ok :

    That will be looking like this inside copyq (even if we dont see it, it's there.

  • Try to paste it inside openoffice with the paste clipboard with Ctrl+V and next with the copyq paste as plain text new shortcut to see if it will copy & paste (process) the data - that will lead that copyq is working but you have only display issue.

I don't have a 'Status Icon' that I can find. Google doesn't list that, and the CopyQ users guide doesn't either. So what is a Status Icon for CopyQ?

I do have the scissors icon in three places. BUT, the program never launches so I can't do what you're way to get into Config? If I right click the scissors icon in the action bar, I get a 'preferences' but it doesn't look anything like what you posted.

I tried everything you suggested here but nothing I did worked. My monitor Prefs shows one monitor. I do get a resolution error message when rebooting but there's nothing I can do about it.

Hi Jim,

Its weird :confused:

Unable to locate package /usr/bin/copyq

Please give us the output of this command :

head ~/.config/copyq/copyq.conf

Next let's start since the beginning. Please do reinstall copyq like this :

Open a terminal and write :

sudo apt remove copyq
rm -r ~/.local/share/copyq
rm -r ~/.config/copyq
sudo apt install copyq

once done, please try again starting it from command line, give us the output and tell us if the try icon of copyq is in the tray :

Also, please give us output of this command after installation :

head ~/.config/copyq/copyq.conf

I'm suspecting that your profile is missing some conf files (not only for copyq)
Do run :

ls -a ~

and check if this folders are there :

You can also do :

ls -a ~/.config/

and confirm that you have your apps configuration there as on my screenshot (not all exactly but you should recognize your apps) :

Good luck there :slight_smile:

Results of Head command; head: cannot open '/home/jim-hitek2/.config/copyq/copyq.conf' for reading: No such file or directory

BTW, when I removed the program using Term, the scissors were still in the Action tray.

No, none of those folders are listed in the screen echo.

CopyQ still doesn't run. This is the output and it fails to launch:
copyq -v
CopyQ Clipboard Manager v3.2.0 ([email protected])
Built with: Qt 5.9.3, LibQxt 0.7.0

I do have many .conf files doing ls -a ~/.config/, but none of them say copyq

So looks like your profile is broken. Maybe you deleted some files that is required for the machine to work.
To be honest, i can advise you to create a new user with the same privileges and start using the new user profile.
You can try to fight with the machine to repair your profile, maybe its some access problems. Maybe some chmod can fix it.
CopyQ and some other apps will fail to load because of that missing conf files.

Okay, well, thanks for your help. I will consider wiping the HDD and reinstalling everything.