Matshita DVD drive not working after UM 16.04 installation

Continuing the discussion from How to install UM 16.04 on an old laptop that has three windows partitions and viruses? Will the UM installer automatically merge all partitions into one and format completely to have a safe system?:

I have installed UM 16.04 but my DVD drive is not working. Here are the specifications according to Disks:

  • Matshita DVD-RAM UJ-861H (1.50)

I am not sure if the drive is recognized properly. Audio CDs or DVDs are not playing. Do I need to install any separate drivers or change anything in the Mount Options?

1 Like

To play DVDs go to the software boutique, section "Sound and Videos" and install libdvdcss2.

Audio CDs though, I think those should work out of the box. Maybe a problem there.

Did you install the Driver & Firmware packages? (Welcome -> Getting Started)


1 Like

Old laptop DVD/CD drives are notorious for failing, one moment they will work and then go on strike, make sure you clean with a CD cleaner and remove the drive, boot the laptop, shut down the laptop and replace the drive and then reboot and I bet it will work again (for one or two times at least!). :smiley:

I installed libdvdcss2 and again updated firmware and drivers @ouroumov, used a DVD cleaning disc @wolfman all to no success.

The cleaning disc was turning a few times without the usual entertainment screen appearing. I tried to open a DVD in VLC and got this error message:

Did you try removing the drive like I suggested?. :smiley:

I removed the DVD drive and booted into UM 16.04, then shut down the laptop. I put the drive back in and booted again but the DVD drive still doesn’t recognize any media. I know this DVD drive is not without problems but it was working under my previous Windows installation, so I guess there must be a way to get it to work under UM 16.04. Any other ideas?

Try booting Ubuntu Mate from a USB stick and then put a music CD in the drive and see if it plays!.

I have had this problem myself quite recently whereby the disk drive would sometimes be there and then on the next boot; be gone!. This happened with Windows and Linux!. :smiley:

I just tried it with several music CDs but the drive won’t recognize any. In Disks the DVD drive is always visible. Am I missing any drivers or do I need to mount it manually?

Check in Dconf Editor > Org > Mate > Desktop > Media Handling:

I just checked these settings in the Dconf Editor and it is exactly the same. I also set it back to the default settings. Music CDs and DVDs still won’t play. In Disks it always says No Media.

It is of course quite possible that the DVD drive is dead?, is it possible for you to replace the drive with a new or 2nd hand one?. :smiley:

Is there anything else I can do? @wolfman @ouroumov
I am quite sure that it was working before and replacing the drive would really be the last option. Do you have any ideas about this @lah7?

Since you say it worked perfectly under Windows, I suspect it’s a firmware issue. I know a modern Apple USB SuperDrive for example refuses to spin media on Linux unless a specific hex command is sent to the drive first. Something similar could be happening here… particularly as it says “No Media” and not “Unknown”.

If the computer is able to boot from a disc, then I’d be sure it’s just a firmware issue between the OS and not a fault of the drive itself.

Does the disc spin at all?