Menu button corrupted

Menu no longer lists programs:
'All' shows the items in Control Center
'Favorites' is empty (never set up)
'Administration' shows the Admin choices from control center
'Preferences' is alphabetic listing of Control Center items

Opening Main Menu in Control Center just gives a quick blink, Right click opens sub menu 'Start Main Menu' which does nothing. Haven't tried 'Remove...'

poked around in root & usr, found several references to menus, but no clues to what was clobbered and how to fix.
should upgrade from 18.0 but not sure I want to risk it without a fix

1 Like

Welcome @Bob_Zirra to the community!

In my opinion, you should upgrade to 22.04.1 LTS. It may fix some of your issues. Not 100% positive, but you may have to upgrade to 20.04 LTS then the 22.04.

I can't solve it for you but I might have a lead you can follow:

Practically all a menu has to do is list a bunch of "desktop files"
Check if those desktop files are still there.
Open a terminal (because , obviously, you can't use the menu) and type (or cut&paste):

caja /usr/share/applications $HOME/.local/share/applications

These should show you a lot of very familiar entries.

  1. If not....time to start worrying because important files like these don't turn to digital vapor by themselves.

  2. If they are there, you might want to reinstall the menu:

sudo apt purge mate-applet-brisk-menu && sudo apt install -y mate-applet-brisk-menu

Or you might want to try a totally different menu:

Rightclick on an empty space on the panel and you can find 3 different menus:
Brisk Menu (default), Compact Menu, and Classic Menu.

1 Like

Thanks Thom (tkn)

Tried the right click in the panel first: Options were the

Brisk menu... just a duplicate of default in panel, still no apps.

Main Menu option: gave a Mate sigil w/ a little tail added: Dropdown had places and system options. no apps.

Mate Menu (advanced) gave a Mint? sigil, opens a menu box w/ Places, System, Favorites with sub options available and an arrow to All Applications which brings up an empty window.

Menu Bar gave the Mate sigil and 3 categories in the panel: Applications, Places, System App just opened a narrow blank dropdown.

Opened terminal, ran: caja /usr/share/applications $HOME/.local/share/``applications : >`` ``F``irst window had more applications ``than I was aware of`` (well over 100), ‘right click & open’ worked fine for those I tried. ``S``econd window (.local) was empty except for a text file: time.desktop ``(opened in Atom, definitions mostly)``.

Ran: sudo apt purge mate-applet-brisk-menu && sudo apt install -y mate-applet-brisk-menu It just reloaded a new copy of brisk , no repopulation of .local

So: I can use /usr/share/applications to load apps,,, not optimal

or just bite the bullet and take the bottom ``disk ``Tb of Windoze 7 or 8 and load the latest and greatest Ubuntu flavor.

Uh oh....That is bad news. Your mate install must be pretty borked.
It can't populate the menu's although the desktop files are there.
Last resort (according to the debian wiki ):

apt reinstall mate-desktop $(apt-cache depends --recurse --installed mate-desktop ||grep '[ ]')

If that doesn't work, your desktop is probably borked beyond repair. That means: wipe and reinstall from scratch.

Sorry for the bad news :pensive:

I hope someone more knowledgable than me could come up with a better plan, but I think this is it.