Menu icons not found on fresh new install 20.04

Hello @lah7

Can you please help and provide an example? about what it's supposed to be the final file?

How can this happen? Many days have passed since the error has been detected and has not yet been fixed. Too bad such a good project has an error being ignored.

O erro ainda segue, sem solução.

I think I speak for all of us if I say: :wink:

How is it possible that this is still not fixed? A fresh installation in Dutch still have this problem.

The solution in post 13 works for the application icons. But I can't get the solution in post 14 to work for the category icons, even after replacing the .mo file.

1 Like

Well, @lah7's workaround works, but in addition you have to do that in all *.directory files located in /usr/share/mate/desktop-directories /
For exemple, take the file:

As you can see, pt, sl and nl are afected and other languages are not needed, so is secure to remove all lines that start with Icon[
sudo sed -i '/Icon\[/d' /usr/share/applications/*.desktop
sudo sed -i '/Icon\[/d' /usr/share/mate/desktop-directories/*.directory
sudo update-desktop-database

Hope this helps!


Brilliant, works for me :+1:

1 Like

Oh, thank you :grinning: These three commands works great :grinning:

So there was no need to edit/replace .po files...

1 Like

It did not work for me the error continues and does not let you edit the file


Center control does'nt show some icon (path missing ?).
All users on this machine are set up ok, only one user got this bad 'look'. No theme setup was made.
Is there a way to "reset" control center ? or ti specify the path / link to hte correct icon ?


It does not seem to be exactly the same problem, my menu shows the correct icons for all applications for all other users on this machine with the same language (fr), this is only affecting one user, only in "control center", any idea on how to edit the "path/link"...or fix this ugly picture :slight_smile: ?
In fact, since release 20, these 2 menu shouldn't be part of de control center, it comes from a restore of the release 18 for that user, do you think I should remove and re-install mate-control-center ? Or is there a config file I could remove / edit / reset /copy ?

It should look like this picture

Ubuntu MATE 20.04.1 was released today. I am disappointed to say that this issue has not been resolved in this point release.

I have updated the Launchpad Bug with this result and encourage everyone that continues to be affected by this to continue to update the bug report to generate more :fire: on this issue.

Please continue to use the work-arounds listed in this thread.

I can only speak for myself, but I do apologize that this continues to be an issue.


The commands helped solve the issue of most icons, only a few could not work, but I appreciate your help!

I think other icons (like Control center, etc) Will be right when you restart X ir Reboot your machine.

Uhm, Linux Mint has this problem too?
Well, you tried to edit it in cmd or with gui? These files are 644, so you only can edit it with super user (it's easier to do that with cmd). Futhermore, I think you should try to get rid of this glitchpeg.desktop file :wink:
OBS: update-desktop-database in this case is only for instantly change icons back to normal after edit them, some icons like control-center, software boutique, etc. could still have problem with icon, Restarting X or rebooting the whole system solves it.

great job! Works fine to me.

Hi, I have come across the same issue, icons on getting displayed, after upgrading Ubuntu 20.04 from Ubuntu 18.04.
The below-mentioned solution worked for me. It might work for others as well:

The issue might have occurred because the installation did not go according to the plans.
The simplest, easy and the most effective operation you can do is:

sudo apt dist-upgrade

This will automatically install/update/repair all the needed packages for your current version.

Hope this helps! :slight_smile:

1 Like

Congratulations from me, it worked perfectly!

Your workaround worked for me:

`sudo sed -i '/Icon\[/d' /usr/share/applications/*.desktop`
`sudo sed -i '/Icon\[/d' /usr/share/mate/desktop-directories/*.directory`
`sudo update-desktop-database`
1 Like

Thanks, works for me