Menu icons not found on fresh new install 20.04

Hello! I decided to try Ubuntu Mate 20.04 LTS after years using Xubuntu.

On a fresh new install I experienced an annoying error on main menu. Some icons are not found. This is a fresh new install (I used all default options in Ubiquity installer from USB pendrive). Please see this image:

Any help to fix it is appreciated!

P.S: I installed twice "burning" a new ISO to my USB pendrive and it still the same =/

1 Like

Olá galera Ubuntu Mate! Gostaria de expôr aqui, que também encontrei este erro nos ícones do menu principal. Mas no demais tudo tá perfeito em minha análise até o presente momento. O Ubuntu não é apenas uma distro é uma experiência Linux.

1 Like

Sorry that you are seeing these issues.

You can add details to this report.

It is important to put the language you are using in the report.

If you have further issues please open additional bug reports. If you don't know how to do a bug report please see this for a how-to.

Thanks

1 Like

I think that looks more like this bug report.

It also affect Slovenian, but if you chose different icon set then default, it may also look like this

As Luke pointed out in the beginning of this post it could be down to translators accidentally translating icon IDs.

I delete all those strings. But I don't know how to download those strings for my language all at once and check if that fix the problem. So if anyone can tell me how, I can try this and report back.

Sorry for the delay. The launchpad issues mentioned in previous answers were confirmed so I think I don't need to write more unuseful information there. I was using Brazillian Portuguese as the installation language, changing to English fixed the problem (even after full install).

Thank you guys for all the help!

1 Like

I did the installation in English, the icons appeared normal, I tried to change the system language or even installs them but it does not change and the language support option appears there but it is inhibited ... I even managed to change the icons by editing one by one but still it was missing from the main menus that do not have this option.

2 Likes

I looked here and the same thing happened,
installed in Brazilian Portuguese.
I will install in English now. Thanks so much

Same problem here in Dutch... with some installations it does show icons, with some it does not. No problem whatsover in 18.04 or 19.04. It happens in traditional and classical menu

Can you guys just add here that you are affected by this bug please.

You can also click This bug affects 4 persons. Does this bug affect you? at the top of the page.

@Leo_de_Kam if you want you can write that some Dutch is also affected by this on launchpad site.

I'm with the same problem.
I made a fresh install of ubuntu-mate 20.04 and menu icons are broken.
The problem seens to be in pt-br version.
Change system language to english fix the icons, but coming back to pt-br breakes again.
I managed to pin a calc sortcut with corret icon in the top bar doing as follows:
-right click on calc from the menu, selec pin to descktop
-in desktop folder edit the calc.descktop changin the line:
Icon[pt_BR]=acessórios-calculadora
to:
Icon[pt_BR]=accessoires-calculator
-and them drag-and-drop to top bar.


Is there a way to make similar edit on the other menu itens?
Thanks

I change icons or add them if they are not default. I download a .png or jpeg (conver to a png) file from the Internet. Now open a root terminal and save your .png file at usr>shar>icons>mate>48x48>app.(I don't usually go all the way to apps, but I save mine at icons)
Then go to System> Look and Feel> Mate Menu. Pick you program, (Mate calculator) and click on properties. When the launch properties box comes up click on the square in the upper left corner with the icon, or missing icon symbol that will open where the icon is saved usr>shar>icons>mate>48x48>apps. Navigate to your icon and click on your icon that will make it the default icon for the system, or just restore the default icon if it is there.
Here is an example of one I have made for Thunar. I have had a lot of trouble with thumbnails showing in Mate for mp3's. If I open them once in Thunar, then they show up in caja after that. I use the traditional theme and didn't like the default icon, so I made my own.thunar-gray

Here is a missing icon. Just look for it where I indicated. I understand if they are all missing editing every single menu item would take to long and is not a solution. Just thought this might help some people.
usr>shar>icons>mate>48x48>apps>accessories-calculator.png
accessories-calculator

@ele nailed the reason - the translator for your locale has accidentally translated the Icon value, so they now point to an invalid icon file.

:terminal: This command will list all the localised Icon[..] keys - they should all be the same (English):

grep -r 'Icon\[' /usr/share/applications/*.desktop

Though, really... there isn't actually a need for all locales to have a localised Icon key.

:warning: There is a hacky workaround - this command will erase all localised icon entries. Take caution.

sudo sed -i '/Icon\[/d' /usr/share/applications/*.desktop

This will fix missing application icons (until a MATE package is updated). Unfortunately this doesn't fix the menu categories (Accessories, Games, etc) which I suspect is compiled into the code (/usr/share/locale/pt_BR/LC_MESSAGES/).

If they were *.po files, they would've been editable in a text editor, but they're *.mo (compiled).

I won't be able to fix this alone - since I'm not part of the :mate: team. :slight_smile: Though, it would be good if a mechanism is in place so future MATE packages don't add Icon[] in the final build.

4 Likes

I've created an issue upstream regarding the category icons:

In the meantime, you could fix these on your computer by:

  • Downloading the PO file for your locale
  • Install poedit
  • Open up the locale and strip out any lowercase/dashed strings that would be an icon, such as:
    • applications-graphics
    • applications-accessories
  • Save this and copy the resulting .mo file to /usr/share/locale/XX-XX/LC_MESSAGES/mate-menus.mo as root (replacing XX-XX with your locale code, e.g. pt or pt-BR)
  • Log out then back in.
1 Like

Well... turns out it's been fixed months ago. Now just needs the project leader (or someone with SRU powers) to add the patch to the existing packages for this LTS release.

1 Like

Thank you very much for looking at this so thoroughly Luke :+1: So hopefully it will be added and updated soon.

BTW do you know where the translations for the programs in for example Preferences (Additional drivers, advance network...) are? Because I notice many are in English in 20.04, but were in Slovenian in 16.04. :thinking:

No problem, bit surprised that this wasn't caught sooner to be honest.


We keep a list on our Get Involved / Translations page - I'll add network-manager-gnome as that was missing:

1 Like

386/5000

[ERROR] The "category icons" in the menu are disabled when the system language is in Brazilian Portuguese. Even if you change the icon theme, the error is not corrected, the icons are not displayed.
It only works in a language other than Brazilian Portuguese.
We are awaiting a position on this as soon as possible.
Overall the best DE in Ubuntu.

Hello, I'm Brazilian and I'm facing the same problem. Will this bug be resolved by updating or do I need to do it manually?

Our project leader hasn't checked in to our team Slack in a while, so there hasn't been an update pushed out yet.

In the meantime, you can follow the workarounds in post 13 and post 14 until an update is actually available.