Menu icons not found on fresh new install 20.04

Thank you very much for looking at this so thoroughly Luke :+1: So hopefully it will be added and updated soon.

BTW do you know where the translations for the programs in for example Preferences (Additional drivers, advance network...) are? Because I notice many are in English in 20.04, but were in Slovenian in 16.04. :thinking:

No problem, bit surprised that this wasn't caught sooner to be honest.


We keep a list on our Get Involved / Translations page - I'll add network-manager-gnome as that was missing:

1 Like

386/5000

[ERROR] The "category icons" in the menu are disabled when the system language is in Brazilian Portuguese. Even if you change the icon theme, the error is not corrected, the icons are not displayed.
It only works in a language other than Brazilian Portuguese.
We are awaiting a position on this as soon as possible.
Overall the best DE in Ubuntu.

Hello, I'm Brazilian and I'm facing the same problem. Will this bug be resolved by updating or do I need to do it manually?

Our project leader hasn't checked in to our team Slack in a while, so there hasn't been an update pushed out yet.

In the meantime, you can follow the workarounds in post 13 and post 14 until an update is actually available.

Hello. My icons from the applications menu are missing. The Live CD of Ubuntu Mate 20 is normal with all icons.

Mostly the categories icons are missing but the calculator is missing too.

Hi @jo_v_co,

please, read this thread:
Menu icons not found on fresh new install 20.04

4 Likes

@lah7 I asked to join the team on https://www.transifex.com/mate/MATE/ to help with future translations, and to complete the missing ones.

I also want to help on this particular problem, helping to identify possible new wrong translations on icon names.

Nice! This particular issue is resolved, since the MATE team updated their build process so it won't use erroneous strings (even if they appear to be translatable) any more. The issue lies with the packager for Debian/Ubuntu to release the fix.

I'm also not a MATE developer nor MATE member, so it's over to their team to approve your translation membership. :slight_smile:

2 Likes

Hello @lah7

Can you please help and provide an example? about what it's supposed to be the final file?

How can this happen? Many days have passed since the error has been detected and has not yet been fixed. Too bad such a good project has an error being ignored.

O erro ainda segue, sem soluรงรฃo.

I think I speak for all of us if I say: https://youtu.be/6ftctdSXEqk?t=28 :wink:

How is it possible that this is still not fixed? A fresh installation in Dutch still have this problem.

The solution in post 13 works for the application icons. But I can't get the solution in post 14 to work for the category icons, even after replacing the .mo file.

1 Like

Well, @lah7's workaround works, but in addition you have to do that in all *.directory files located in /usr/share/mate/desktop-directories /
For exemple, take the mate-office.directory file:


As you can see, pt, sl and nl are afected and other languages are not needed, so is secure to remove all lines that start with Icon[
sudo sed -i '/Icon\[/d' /usr/share/applications/*.desktop
sudo sed -i '/Icon\[/d' /usr/share/mate/desktop-directories/*.directory
sudo update-desktop-database

Hope this helps!

1 Like

Brilliant, works for me :+1:

1 Like

Oh, thank you :grinning: These three commands works great :grinning:

So there was no need to edit/replace .po files...

1 Like

It did not work for me the error continues and does not let you edit the file

Hello,

Center control does'nt show some icon (path missing ?).
All users on this machine are set up ok, only one user got this bad 'look'. No theme setup was made.
Is there a way to "reset" control center ? or ti specify the path / link to hte correct icon ?

Thanks

It does not seem to be exactly the same problem, my menu shows the correct icons for all applications for all other users on this machine with the same language (fr), this is only affecting one user, only in "control center", any idea on how to edit the "path/link"...or fix this ugly picture :slight_smile: ?
In fact, since release 20, these 2 menu shouldn't be part of de control center, it comes from a restore of the release 18 for that user, do you think I should remove and re-install mate-control-center ? Or is there a config file I could remove / edit / reset /copy ?

It should look like this picture
mate-control-center