Mesa 20.0.8 - Prominence Poker frezes at startup

AMD Vega 56
The problem didn't occur with 5.4.0-56-generic
Installed ppa which could be related:

Everytime i start the game Prominence Poker with proton I get this:

I think everything is running in the Background quite normal (I think i see changes "behind" the graphic bugs) and the curser (which can also be seen on the pciture) is normal.
But i can't make any input.

I switched back to the old kernel, but i want to report this, because i couldn't use this kernel version for an ethernity^^

Another proton game (Rocket League) didn't crash, but i only tested it for a short time.
(When starting Prominence Poker the crash is happening!)

I reported this here, too:

The kind of issue is known to developers; I suffer similar in selective cases. You could further report some technical details here.

No, this is another bug, i don'T think its related

Well, perhaps, hard to tell on my part.

Even though, software crashing on 'Ubuntu MATE' 20.04.1 - kernel 5.4.0-58-generic - in my case, looking the way similar to what you have also talked about, works just fine under an older, independent XFCE-based distro, under the 'VirtualBox'.

Here is my primary forum entry, related to the problem.

Seems like 20.04.1 is not a very fortunate edition for the 'Ubuntu MATE'.

The other bug looks like this:

I had this bug too:

But as today Adaptive composit (this was the problem in your mentions thread) is active and it worked flawlessly until Kernel 5.4.0-58.

Then I hope they fix it.

Okay, it occurs with Kernel 5.4.0-56, too.
I removed the Mesa ppa and test if it changes anything.

(Purging the PPA activates the the bug @MSX mentioned XD )

Okay, i think it's a mesa and/or marco related bug.
Without the ppa and Kernel 5.4.0-58-generic i had to deactivate Adaptive composit of marco.
See this Bug:

Then I started Prominence Poker and it freezes with a black screen, but the system isn't effected.
Will try the ppa with disabled adaptive composit of marco.

I expect a black screen of prominence poker aswell but i don't think the whole system will crash.

Okay, with disabled adaptive composit of marco the whole system crashes.

Now i have to problems:
Without ppa Prominence Poker get a black screen
With ppa: When starting Prominence Poker the whole system crash.

Yesterday i played prominence poker without a problem, but i don't think it's a kernel related issue.

Can i look up a update history?
I want to see which packages i updated yesterday.

Okay, my conclusion:
Without the ppa only the game freezes.
With the ppa the whole System freezes.

Yesterday, before i applied this patches everything worked with the ppa...
cat /var/log/apt/history.log

Start-Date: 2020-12-28 16:52:23
Requested-By: jokergermany (1000)
Install: libgail-common:i386 (2.24.32-4ubuntu4, automatic), libgtk2.0-0:i386 (2.24.32-4ubuntu4, automatic), libgail18:i386 (2.24.32-4ubuntu4, automatic), libatk1.0-0:i386 (2.35.1-1ubuntu2, automatic)
End-Date: 2020-12-28 16:52:24

Start-Date: 2020-12-28 23:29:36
Commandline: aptdaemon role='role-commit-packages' sender=':1.268'
Upgrade: libegl-mesa0:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libglapi-mesa:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libglapi-mesa:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libxatracker2:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libegl1-mesa:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libgbm1:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libgl1-mesa-dri:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libgl1-mesa-dri:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libosmesa6:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libosmesa6:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libgl1-mesa-glx:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libgl1-mesa-glx:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), mesa-vdpau-drivers:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), mesa-vdpau-drivers:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), mesa-vulkan-drivers:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), mesa-vulkan-drivers:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), mesa-va-drivers:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), mesa-va-drivers:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libglx-mesa0:amd64 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2), libglx-mesa0:i386 (20.3.1+git2012162009.4a87e444134fmesarc2, 20.3.1+git2012231915.b41a3c8a1d4fmesarc2)
End-Date: 2020-12-28 23:29:45

I think its a Mesa related bug.

I need to get back to git2012162009.4a87e444134

This is how you organically turn Linux into a kind of game.