Missing etc/apt directory and others

After trying to help myself with this problem I have not found a solution.

Here is the message I get when I open Synaptic: W: Unable to read /etc/apt/sources.list.d/ - DirectoryExists (2: No such file or directory)
W: Unable to read /etc/apt/sources.list - RealFileExists (2: No such file or directory)
W: Unable to read /etc/apt/preferences.d/ - DirectoryExists (2: No such file or directory)

I have tried recreating them with mkdir but it will not and I have tried retrieving it from my backup but it will not. Any suggestions? Thank you.


Hi mrjoeyman

What do you see in /etc/apt? This is what it should look like..

Hi @mrjoeyman,

see also:

1 Like

There is no Apt directory in /etc. I have no idea how it got that way. I made an apt folder in /etc, now I need to know what should be in it.

Update: Ok I am getting closer. I created the directories that Synaptic is looking for but now I have an authentication problem:
W: GPG error: http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 40976EAF437D05B5 NO_PUBKEY 3B4FE6ACC0B21F32
W: The repository ‘http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease’ is not signed.
W: Data from such a repository can’t be authenticated and is therefore potentially dangerous to use.
W: See apt-secure(8) manpage for repository creation and user configuration details.

How can I get the public keys?

Its a fairly straight forward process. Are you up for a little homework?


1 Like

Yes sir. Its what I have been doing for an hour now. I will try to get it on my own. :slight_smile:

If you run into a snag please post back :slight_smile:

Apparently I fixed it. There are no more error messages upon opening Synaptic. Thanks.

So this is solved?

Well done :slight_smile:

Solved thanks to you. I marked your post as such.