Missing Maximize/Minimize/Close icons all windows

Hi there Noob here AGAIN sorry
so I am working AT my machine ( not remotely as I thought that was the problem)
and I open up control center to change something and all the control icons at the top of the window disappear! I’m talking about the Maximize/Minimize/Close icons. So the window is effectively orphaned.

NOW I here you say “GOOGLE BEFORE ASK” and I reply have done but VERY worried that I will break more things that will have to be mended later on as I don’t know what is good advice and what is bad.

It sounds like you’re using Compiz, which happens when the driver/hardware in use is not capable of using the graphics hardware to render window borders. Or Compiz’s profile (configuration) is messed up somehow.

Switch to Marco (the default CPU-based compositor) in MATE Tweak (System -> Preferences -> Look & Feel) and/or reset Compiz from there.

well I’m using a Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] specifically the hd5450 so it’s pretty common isn’t it?

I can’t use marco as the hdmi movie screen tearing issue will reoccur which is what started most of this in the first place, see how frustrating this all is.

I had a similar problem with Compiz using the very same Radeon GPU.

My solution was to install Compton compositor. If you want to copy my solution, go to a terminal and type:

sudo apt-get install compton

Once installed, close the terminal and go to Mate tweak and set your windows manager to Marco. Also, if it is selected, deselect compositing for Marco. You are going to get Compton to do that instead. Then close Mate Tweak.

Then, go to Startup Applications and type the following command in a new startup entry:

compton -c -m 0.8

The above command will give you full compositing, so that you will not get any screen tearing. Also, the c and m switches will give you a slight shadowing under menus and panels and will also make your menus slightly transparent. If you don’t want the switches, just type compton as the command. Then close Startup Applications

Log out and then back in again and it will all be working.

Hey steve
If I do this will the world come to an end? I ask because I am a noob at this stuff and so far I “think” I have made matters worse :slight_smile:

ALSO will this survive any updates I will apply over time

thank you for you reply it really was nice of you

I’ll do you a vid of how to do it. It’ll take me about five mins. Hang on…

hey Steve
please I can figure out how to do it without you going to all that trouble thanks though. I just am a little frustrated right now

don’t worry about it mate. I have done the vid and am just uploading to youtube. Will be up on here in a jiffy…:slight_smile:

Don’t worry about feeling obliged to do it just cos I posted a vid either. If you want to do it, do it. If not, then it is here for anyone else who might want to.

1 Like

Hey steve
you are a great man and santa will bestow many blessings on you and yours :slight_smile:

I will do the procedure and report back, my wife is watching the tv right now and the machine is hooked to it, if I mess with it she will probably give me a “gift” in the happy sacks

thanks again this stuff really helps and increases my knowledge and, hopefully, decreases the amount of times I bug you good folks

Here is the vid showing how to do it. Ignore the screen lag. that is not my system. It is “RecordMyDesktop” application playing up. I think I need to drop the frame grab rate.

1 Like

also, it will be fine with updates

I thank you for doing that and making it so clear. When Santa gets here we will make him turn around and revisit the Cook household and delivered a fresh batch of frame grabs, my treat :slight_smile: seriously though Steve this is really helpful to me and I suspect others.

thanks again

1 Like

You’re welcome Theakston

I see you spotted the missing T in theakson :slight_smile: thank Steve I have done the mods and so far nothing has caught fire. This has made my day truly, I am so pleased that I found the mate community and hope one day to help contribute.

have an excellent xmas and a happy new year. You have MANY MANY brownie points in the theaks(T)on household


Hey Steve
sorry to report I spoke too soon. The menu icons are missing again and when I stream movies the frame jag is back. I followed the instructions to the letter, how could I not with such an awesome video, but the problems remain. I’ll leave it the way it is and see if it keeps happening. thanks so much for your support and I learnt how to add things to the startup which is AWESOME
thanks again

That's disappointing to hear Theakson. Sorry to hear that. Just check the following:

Is Mate Tweak set to Marco without compositing enabled?

Is Compton properly installed? You can check this by going back to a terminal and typing:

sudo apt-get install compton

If it is already installed, you will get a message along the lines of: "compton is already the newest version". If not, install again.

Is the compton command in the startup applications list?

If it is, then fine. If not, or if it is put in incorrectly, amend and/or re-apply

If all of the above is in place and it is still not working, then go to a terminal and type the following:

compton -c -m 0.8

Then minimise the terminal (don't exit it) and see if Compton is working (lack of screen tearing etc). If it is, report back here and I will tell you how to proceed to make it permanent.

one other thing, are you using the propriety driver or the linux generic one? GPU based compositing only works properly I have found with the propriety driver

He is still in the process of sorting his GPU in another thread!:

thanks Steve and as Wolfman says I am still sorting out my GPU which I am sure will make you solution work.

go off and have a well earned xmas break and thanks again for being a genuinely good guy

Merry Xmas Theakson. See you on the other side…:slight_smile: