Missing Skype Update

My Skype tells me I need to update. Is Mate still offering updates for
Skype or should I attempt to update otherwise? Mate use to offer those updates for Skype.

Skype.com hosts the skype repository (=software store).
Mate Boutique added the skype repository URL to your system and did the install
but that is about it.
Your system pulls the updates directly from skype.com

So when microsoft (skype.com) publishes a skype update for Linux in this repository it should automatically arrive like your other updates.

That is, at least, how it is intended to work (without any further action needed)

It could be, though, that the Linux version has a bit lower priority for microsoft than the Windows version which would result in a somewhat later update.
OTOH ... It could be that something at skype.com went sideways so you could check if other channels/distros have the same issue.

I just downloaded (without installing) the most current version directly from skype.com and checked the version-number

Package: skypeforlinux
Architecture: amd64
Maintainer: Skype Technologies S.A. [email protected]

You might check if this version is the same as yours.
if it is, you're up to date.
if it isn't, you might expect an update soon.

This is what my Skype has been telling me for weeks. I don't know if you will be able to see the image. It says an update is available. My version is older than the one you downloaded.


First check if the repository is still enabled in 'software & updates':

(as you can see, i don't have the skype repository, but if I had, it should be in this list)

If it is, then repo.skype.com has not been updated by microsoft with the new version.

you could then download the file from skype.com directly and use 'gdebi'(GUI) or 'apt'(CLI) to install it.

Thanks a bunch! I checked and it was not enabled. I enabled per screenshot below.


Good to hear that!

If it finally successfully updates, would you be so kind to mark this thread as solved then ?
It could be helpful to other users :slight_smile:

I certainly will do that. Thanks....again...
I am a moderator on another computer help forum and I know how valuable
good advice is....I would give the website but I don't want you to think I'm a spammer.

1 Like

What if anything can I do about this?

As far as i can see, the repository is not signed.

Hmmm...it is a known problem, see this:


According to the article you can obtain the signing-key seperately.
If you copy and paste this in a terminal you should be good to go:

curl https://repo.skype.com/data/SKYPE-GPG-KEY | sudo apt-key add -

1 Like

This is what happens when entering that command.

Ah, you don't have 'curl' installed.
Well then. Install 'curl'

sudo apt install curl

and then:

curl https://repo.skype.com/data/SKYPE-GPG-KEY | sudo apt-key add -

Does this look right?

Yes that looks about right. You should be able to update now. :slight_smile:

Thanks for sticking with this....seriously. Problem SOLVED!


1 Like