Modprobe: FATAL: Module nvidia not found in directory /lib/modules/6.2.0-25-generic

Until today, nvidia driver was working, per both nvidia-smi, and the gui from software and updates, additional drivers, and glx info
now, I am getting the above error.

I have tried numerous solutions, all variants of the drives, finally did fresh install, same error.

any ideas?

there also seems to be an acpi error in dmsg: ACPI BIOS Error (bug): Could not resolve symbol [_TZ.ETMD], AE_NOT_FOUND (20221020/psargs-330)

which has not appeared heretofore. Are they related?

The first clue was upon reboot the nvidia temp sensor was not working in the sensors app, which is what sent me on this wild goose chase.


( tl:dr -> Roll back to a previous kernel version. )

They are totally unrelated but have one thing in common: The kernel.
Your software updates probably brought you a new kernel.

How does this affect two totally different pieces of your computer ?

  1. nVidia drivers are the only GPU drivers that are not in the kernel tree.
    That means that it is the only GPU that regularly has driver issues when updating a kernel. nVidia is often late with a fitting driver for a new kernel.
    Normally the wrapper-code that interfaces with their binary blob has to be compiled with DKMS (this is supposed to be done by the updater automatically).

It could be that something went sideways there, it also could be a pure driver bug which can't be solved by anyone (no sourcecode) except nVidia.

  1. Most BIOS/UEFI firmware is deviating a lot from the official ACPI standard (to appease Microsoft because Microsoft is unable to support standards) and therefore not very reliable (not to say horribly buggy).
    This has resulted in that Linux has a lot of workarounds for these bugs incorporated.
    Probably one of those workarounds has been accidentally dropped out of the kernel.

Most ACPI bugs are competely harmless and only a testimony how badly OEMs can butcher a standard.

More info here (different kerneversion but the same idea):

If you want to solve the ACPI problem:

  1. file a bugreport to the ubuntu-kernelteam here:
    Bugs : linux package : Ubuntu
  2. roll the kernel back to a known working version

If you want to solve the nVidia problem:

  1. file a bugreport to nVidia
  2. roll the kernel back to a known working version

also, if the previous solution didn't work or if you are experimentally inclined:

  1. try to reinstall the nVidia drivers.
  2. try different nVidia driverversions if that is needed.
  3. promise yourself to never buy nVidia again.

Dear T,

Thank you. this made total sense.

What I want is an older kernel, older nivida driver, but latest evolution, &c, and, up until now, nothing has gone wrong with the auto updates.

I think if I install LTS, and do not deploy HWE, all will be well, except I am concerned that the latest programmes sometimes drag in a kernel update.

So what I really want is today's prgrammes with a two year old kernel.

By the way, it is interesting how many of the nvidia drivers have been dropped from teh repository.

Is there a way to install a 5.19 kernel, and 515 nvidia driver easily in 23.04 without losing anything I really need like the latest skype, evolution, zoom, &c?

Your post was truly helpful.


There is a very high probability that that will work.
The Linux kernel is known to (almost) never breaking userspace.
This means that the interface (API) either to libc or to the kernel doesn't change.
In other words: new applications should not have any problem with running on an old kernel in 95% of the setups.
This makes for good stable and long term usable kernels.
Also , lots of old kernels still get security updates.

That depends on the Ubuntu-MATE version you are running.
On Ubuntu-MATE 22.04 LTS i have this choice of 5.19 kernels:

linux-image-5.19.0-32-generic - Signed kernel image generic
linux-image-5.19.0-41-generic - Signed kernel image generic
linux-image-5.19.0-42-generic - Signed kernel image generic
linux-image-5.19.0-43-generic - Signed kernel image generic
linux-image-5.19.0-45-generic - Signed kernel image generic
linux-image-5.19.0-46-generic - Signed kernel image generic

and this is the list of fitting nVidia blobs:

linux-objects-nvidia-515-5.19.0-41-generic - Linux kernel nvidia modules for version 5.19.0-41 (objects)
linux-objects-nvidia-515-5.19.0-42-generic - Linux kernel nvidia modules for version 5.19.0-42 (objects)
linux-objects-nvidia-515-5.19.0-43-generic - Linux kernel nvidia modules for version 5.19.0-43 (objects)
linux-objects-nvidia-515-5.19.0-45-generic - Linux kernel nvidia modules for version 5.19.0-45 (objects)
linux-objects-nvidia-515-5.19.0-46-generic - Linux kernel nvidia modules for version 5.19.0-46 (objects)

The earliest kernel I have in the repository is 5.15

If you can't find the kernel you want in the repository, you can find it here:
Choose the kernel you want and select the '.deb' version for download.
You don't need to install the nVidia drivers yet, just try the new kernel out first.
You might not need the nVidia-drivers for your usecase.

If you really need the proprietary drivers (or need the challange), you might try nVidia:

The other (not so easy) way is downloading and installing manually the needed packages from:
And search for packages for jammy (22.04 LTS)

I have no recent experience with nVidia ( only AMD and Intel here ) , so this is how far I can lead you.

Good Luck :slight_smile:


Dear T,

Since I have a /home partition, it is better to go to the LTS, and you are incredibly helpful.

Many many thanks, and, yes, next time AMD!

Very best wishes,