Monitor Preferences scaling is not persisted after a reboot (discrete only graphics)


I'm not sure if this is a bug or not. I'm running Debian 12.4.0 with my nvidia GPU in discrete only mode. The discrete only part may be crucial, I went into the BIOS and changed that, the default is hybrid which will use both the intel HD graphics and the nvidia card.

Aside: I don't do Hybrid because back in the 2010s (not this laptop) if I didn't run a program with bumblebee that expected a GPU it'd hard freeze my whole computer, and it was a real pain to try and figure out what applications needed that and which ones didn't (there were some programs where it wasn't really clear at all whether they needed the nvidia chip). It was also a real pain to handle programs that called other programs, sometimes a script/etc didn't launch some subprocess with bumblebee like it should have, and then I had to track down that script or program and modify it. Maybe things got better since then, but it was such a terrible experience that I'm not really inclined to try it again. I'm not concerned about losing some battery life, I'd rather just simplify my life and force everything through the discrete card. Even on Windows I've had weird issues with Hybrid graphics sometimes.

On boot the scaling on my computer (Lenovo P53) seems to be reverted to something scaled down significantly (as in, things are way too big on the screen). This is a pretty high resolution laptop, the default setting for Windows was to do this too.

I can fix this just by going into Monitor Preferences and changing it from auto-detect to 100% or back, but I have to do that every time I turn on the computer. It seems like just changing something and hitting Apply fixes it

The permanent fix that's working / persisting seems to be to edit /etc/lightdm/lightdm.conf and put this in it:

xserver-command=X -dpi 96

I figured this out by adapting the solution from How to find and change the screen DPI? - Ask Ubuntu

Also... I guess while I'm here, there was one other customization I had to do for this P53, the Mate GUIs and keyboard keys for setting backlight brightness don't work and didn't work in any distro I tried on this laptop, but they do work on my Dell Latitude.

My duct tapeish workaround for that is to manually edit this file: /sys/class/backlight/nvidia_0/brightness, this file just has one number in it.

For example, 10 is 10% brightness. 100 is 100% brightness. This seems to work pretty well.

Hope that helps

PS: If this is a bug, what product should I report it against? Where does the source code for Monitor Preferences live? I know C/C++, I might be able to look into it.

Update: I found a reddit thread that said the source for Monitor Preferences is here, but I did not validate this yet

1 Like

Welcome @jwaffe to the community!

I thought about it and I think this might be a bug

I posted an issue here Monitor Preferences scaling is not persisted after a reboot (discrete only graphics) · Issue #741 · mate-desktop/mate-control-center · GitHub

Debian bug report
(I think I messed this one up sorry, I think I specified the wrong package!)

Unfortunately I have no idea where to report the backlight thing... I'm not sure that's even a Mate thing. Sorry I'm just not all that clear on what is shipped as part of what when it comes to DEs, I wasn't even sure at first if Debian was using LightDM