Monitor with no signal

I've installed Ubuntu MATE with desktopify on a Raspberry Pi 4, got it running, all this in my LG TV.

Now I've moved the Pi to my office, bought an LG monitor (24MK430H-B) and it says that it has no signal.

I plug it to my PS3 and the monitor worked fine. The Pi is running on other TVs with HDMI using the micro HDMI cable.

I've flashed the OS again. And tryed to boot it with the LG monitor. Didn't worked. Then i plugged to the TV, installed it,pulled the HDMI from the TV into the monitor. And it was working with 1920x1080 res. At 60Hz. But when i reboot, or shut it down and try to Turn the pi on again it dosen't detect the signal. If i remove what os writen in the boot/firmware/usercfg.txt (
" disable_overscan=1
dtoverlay=vc4 - fkms - v3d
hdmi_drive=2") then i can't even have image on the monitor.
I have been told wonders of this distro by friends who are using it and had no problems.
Só what can do?

I have the same problem

Some monitors/TVs have odd limitations. If you can SSH to the system when it is booted, but showing no output, it will be possible to extract more information. If not, then you will need to work with the system when you can get output to find config details which can be set in usercfg.txt to render it usable. If the command tvservice exists,you could use it to create a suitable edid file.

please check HDMI cable.. because i had same problem but now all ok
use good quality micro HDMI cable..

I was going to buy a HDMI-Micro HDMI adaptar to use with the cable that came with the monitor. I'm going to try that first. Thanks

The cables are fine and i did what Dan Said... Nothing difrent so far...

If, By 'Dan', you mean me, then I suggested lines of attack, but nothing specific - so whar did you try?

I've noites on the TV again, unpluged and plugged black on the monitor. And then i got to usercfg.txt . I Saw other fóruns with some examples and erased the usercfg.txt. then i forced the resolution and nothing. On another fórum, a Raspberry One, i got a tutorial:
This One i've still didn't tryed.
I'm noob on pi and Linux xD