Mouse movement causes freezing

I've just upgraded from 20.04 using UI (not Terminal). Everything was finished without any errors. The OS was rebooted OK. I see the only but severe issue - mouse movement freezes everything. For example, the video is frozen in VLC, while I move mouse across the screen. Windows dragging is extremely laggy. I tried to look at System Monitor, but it doesn't show any CPU usage peaks while I move the mouse.
So, what could be the reason?

I have wireless Logitech mouse, attached to USB2 port of the Pi. I have Pi 4 with 8GB RAM. 20.04 worked without any problems.

Looks like I've found the problem reason. It was here:
/boot/firmware/config.txt:
dtoverlay=vc4-fkms-v3d change to dtoverlay=vc4-kms-v3d i.e. just remove "f" letter :slight_smile:

After that I've changed windows manager in Mate Twek to either XPresent or GLX (both work fine for me).

Further investigations show, that "kms" overlay randomly disables HDMI while video is playing. It happens in both 20.04 and 22.04. Though it works good unless I'll play a video.
'fkms" overlay never disables HDMI and it works fine in 20.04, but it is very laggy in 22.04. So, 22.04 is useless for me, if I consider to watch movies. In all other aspects 22.04 looks better than 20.04.

Hope this bug can be fixed...

Have you seen any more information regarding this issue?

I too have the same issue on any Ubuntu distro. Moving the cursor causes the display to freeze until its stopped. Playing videos in any player randomly has the HDMI connection blip out for a second.

These issues stop when not using the fkms driver. Of course the downside is that there is no hardware acelleration for anything. Such as decoding. Watching videos with the Open or KMS driver is a slideshow. Less than 30fps looks like.

1 Like

Welcome @QuinnLion to our community!