Mouse too fast in 18.04 again - known methods stopped working


I have this issue over years already on my private system: the mouse is way too fast, though the graphical setting for speed is set to the minimum value.

The solutions for this problem that I found in the past were different and I had to research for an adapted/alternative solution at each system upgrade.

These are the three solutions I know from the past:
xinput set-prop “Device Name” “Device Accel Profile” -1
xinput set-prop “Device Name” “Device Accel Constant Deceleration” 10
xinput set-prop “Device Name” “Device Accel Velocity Scaling” 5
xinput set-prop “Device Name” “libinput Accel Profile Enabled” 0, 0
xset m 3/2 6
xinput --set-prop “Device Name” “Coordinate Transformation Matrix” 1.0 0.0 0.0 0.0 1.0 0.0 0.0 0.0 1.5

Now I am facing this problem on my business system, after having received a new mouse.
But all the above solutions stopped working now! They seem to have no effect at all.

There is one exception: The last solution works for influencing the mouse speed, but it breaks the mouse positioning for Easystroke gestures (which is annoying), but also for Synergy/Barrier (which is a show stopper).

Additionally I tried setting these two option via dconf-editor:

But still no change in behaviour.

I assume that mouse acceleration is disabled already on my system and the basic speed of the mouse simply is too fast. It should be possible to adjust the mouse speed to extremely slow and extremely high speeds via GUI, regardless what is happening under the hood.

Doing researchs at each system upgrade to find out some CLI hacks every time again and again is really annoying. Using the mouse is a basic feature of a computer system, so this problem is a really hard PITA.

What can I do to bring Ubuntu/MATE to a state that this problem will be solved via GUI one and forever?

Thanks for any help.

Does changing values via menu System!Preferences!Hardware!Mouse not work for you?

Sorry Dave_Barnes, I’ve already stated that this is set to minimum already:

This is the whole point of the problem… :wink:

No it is not. The graphical setting is unitialized. Move both acceleration and sensitivity to middle and then click close. Reopen the mouse preferences and adjust acceleration and sensitivity as you need.

1 Like

wowowowowow this procedure is soooo weird … but it works!!

I have searched and asked in many different locations for help regarding this topic over the past years, but no one came up with this weird but simple solution!

Tons of thanks, you can’t imagine what huge improvement this means to me now!

IIRC the app can’t read the default values. Once you set the values, the mouse settings stay as set. I think the GTK2 mouse preference was this way 10 years ago too.

Hmm … so the UI could be improved with having the whole slider settings/area disabled by default and a checkbox to enable them.

So, when toggling the checkbox to enable the sliders, the current setting of the sliders (wherever they are) can be applied. The user most probably will notice a significant change of the mouse speed then, which is quite intuitive and expected after the change. Afterwards, it is completely clear to the user to being able to adjust the sliders to achieve the desired behaviours.

Not sure how/where/if it is needed/possible to close the dialog in between the process though…