Mousepad / Touchpad not working in 19.10 Ubuntu Mate

Hello - I upgraded to 19.10 Mate, my mousepad didn't work, so I did a fresh install of 19.10 and it still doesn't work. A usb mouse works, but not the laptops touchpad. My laptop is an HP Stream 14. Hoping someone may be able to help me get this fixed...
Thanks,
AleutGerl

Here is a copy and paste of xinput:
[email protected]:~$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Logitech Optical USB Mouse id=10 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Video Bus id=7 [slave keyboard (3)]
↳ Power Button id=8 [slave keyboard (3)]
↳ HP Webcam: HP Webcam id=9 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
↳ HP Wireless hotkeys id=12 [slave keyboard (3)]
↳ HP WMI hotkeys id=13 [slave keyboard (3)]
[email protected]:~$

I don't think my touch pad is showing. The logitch Optical USB Mouse is the usb mouse I'm using while I try to fix the touchpad...

I got this fixed using the following video:

youtube.com/watch?v=wDtJooJJfFE

1 Like

Welcome to the forum, and thanks for sharing the solution! I hope it works out fine for you in the long run. I have an old Chromebook that I have been struggling with on Ubuntu Mate. It fixed it self when I installed 19.10. I have bookmarked this for future reference!