MultiBoot program that works?

I’ve tried MultibootUSB, MultiSystem and can’t get either to work. I have Wine on here, does anyone know if Yumi will actually work in Wine?

Do I actually have to find a Windows system to make a Multi Boot USB?

Yumi works with wine. Multiboot usb has a native linux version for this task that works well in my experience.

Not on my box. I’ve been waiting since just after my last post for Yumi to finish with the persistence thing - but it is just hung. Same on the other box. These things just don’t work, at least not on my machines.
And Multiboot goes through all the motions, but DOES NOT BOOT at all. Same with MultiSystem - on 2 different machines.

Like, WTF? I really don’t get it - all the single-distro boot USB thingies work - wassup here?

I guess I have to go back to Windows.

Of course, I always have to keep this in mind (as in Post #3)

I’ve just spent an hour trying to do this on a Windows laptop - Yumi can’t even finish one run. It crashes.

Seriously, how am I messing myself up here so that things that “supposedly” work never work for me? Programs, scripts, logic, they work. But not hardware. Weird as f**k.

(not whining - really puzzled)

Are you trying to multiboot Windows and Linux? If so, I will take you through the steps

I actually had a rooted android phone just for this. :blush:
This app to booted ISO images
I would just copy iso file to a folder on the SD card and later mount with DriveDroid.
It was a little slower to copy and boot images because of the SD card speed, but it worked.
It required rooted Android.

I’m trying to build a multiboot USB with several Linux distros on it - no windows -for exploration’s sake.
Nothing I’ve tried in Linux has worked, not even Yumi in Wine.

But I have borrowed an old Windows 8 laptop and Yumi seems to be able to do it there, although it keeps choking on openSUSE for some reason.

I am most definitely going to check out that DriveDroid, thanks, Misko_2083

MultiSystem works fine for me since more than one year.
I built an USB-Stick with 4 different Linux distros for myself and for our local user group.

As an example, let’s assume you want four linux distros on one USB that has a capacity of 30 GB

Load the USB into Gparted.

Divide the USB into five partitions. Four of them empty ext4 partitions of 6 GB each and one partition set up as a swap partition of, say, 6GB. Obviously, you can play with these numbers in terms of size of partitions.

Then close Gparted.

Then plug another USB into your machine. But, also leave the USB you have just partitioned, plugged in as well. The newly plugged in USB should have the first of your distro installation ISO’s on it. Then reboot your machine to boot to the USB with the ISO on it. When it has loaded, choose the “other” method (or whatever the specific Linux distro you are installing calls the “other” method) for installation and pick one of your four ext4 partitions on your first USB to install it on.

When you have completed the above. Repeat for the other three distro, installing each of them on one of the remaining empty ext4 partitions on your first USB.

Once completed, you should find that the grub boot loader of the last one you installed will take over the booting of the system. And, if you press the Shift key on boot, it will bring up the grub menu which will display the other three installed distros. If it does, you are done. If it does not, then let it boot to the distro it is displaying. Once in there, fire up a terminal and issue the following command.

sudo update-grub

(or, whatever the specific Linux distro variant of the above command is)

Then reboot and check your grub boot menu to see if the other distros are now in the list.

If they are not, then come back on here and let me know and I will tell you what to do next.

Yumi on Windows 8 is working for now. But I’ve saved your instructions for future reference, stevecook172001. Thanks.

I believe i have my answer - it looks like hardware failure.

Intermittent but total failure of all USB ports on one box, intermittent south bridge on the windows laptop, and the other linux box just keeps getting little unidentified “system errors”

or it could be this:


multisystem has just been updated with support for the 20.04 releases. I have just completed setting up a 32GB with all the flavours and some other distros. If you want it to work properly format your USB stick from within the program. Use the version from the PPA for best results.

If this community ever ends up having an "Expert NecroThreader" badge (or similar) then award me one!

All joking aside, I am taking the liberty to necro bump this because if you're like me you have been trying for MANY years to easily stuff a couple of distros on a unique USB key. And it always ended up not working so well for you also. Or it ended up working for a very minimal period and then you managed to break it without caring to ever fix it back.

Well rejoyce because those times are now behind us as finally have The Tool: Ventoy

Our good buddy Abhishek covers it on his great website: How to Install Windows After Ubuntu Linux in Dual Boot but in a nutshell the steps are very easy:

  1. Download Ventoy + extract it ( ;
  2. Download the ISOs you wish you run;
  3. Execute Ventoy and install it to your USB drive;
  4. Copy/Paste the ISOs on the newly created partition.

Voilà, your multiboot environment is ready to use. That was easy, as it should had always been!