My Intel laptop does not use 3D acceleration, it only has LLVM


I have spent most of the week trying to diagnose a problem with my 3D configuration on Ubuntu MATE. I have a laptop which uses Intel UHD 620, and has always worked fine. But now, it does not correctly load the 3D driver, and falls into LLVM (so, software rendering). Even Blender moving a single cube is terribly slow. I have checked everything that I can think of. Just tell me what information you need and I'll provide it. As for now, "glxheads" command tells me that my graphic card is a generic "Mesa", and GL renderer is llvmpipe. I have checked the error logs and found no error. Everything seems to load correctly.

What is even more strange, a similar PC (just one generation before, UHD 530) works perfectly with the same Ubuntu MATE.

Could it be this ? :

1 Like

Thank you, it's exactly that, but I don't have EagleCAD installed. I have had FreeCAD, but not now, I have uninstalled it. How can I discover the problem?

1 Like

I have no idea yet but can you check if


is empty ?

Also please post the output of:

grep 'GRUB_CMDLINE'  /etc/default/grub
inxi -G
glxinfo |head
glxheads :0
apt search intel |grep intel |grep '\['
apt search xpresent
apt search picom |grep picom

I can't promise a solution but at least I can try , right ? :slight_smile:

Also check this link:


Here you have it, thank you very much!

all the command output

Here is where it goes sideways :

libGL error: did not find extension DRI_Mesa version 1

Which might be related to:

but this:

libGL error: failed to load driver: i965

and this:

Display: x11 server: X.Org v: driver: X: loaded: intel gpu: i915

While my own laptop shows:

Display: x11 server: X.Org v: driver: X: loaded: modesetting

Makes me wonder if it tries to load the wrong driver, especially since I found this same error as a thread on the Linux-Mint site:

Linux Mint 21 versions do not use i965. The i965 renderer was used in Linux Mint 20 versions, but switched to crocus in Linux Mint 21 versions because of changes in the underlying graphics stack.

Also, your system should not be using the intel display driver. It is showing as an alternate which means you must have done something to try and force it to load. That may be why you are getting llmvpipe.

Display: x11 server: X.Org v: driver: X: loaded: modesetting
unloaded: fbdev,vesa alternate: intel gpu: i915 display-ID: :0 screens: 1

According to my laptop, the following directories should not contain any intel related files:


Also the following mesa packages should probably be installed:


Remove the intel package (if you added it) and any references to it you might have added to any files and reboot the computer and see if the proper renderer loads.

Hope this helps :slight_smile:


Thank you again!! I have carefully read your answer and checked everything. I have installed some libraries required by Steam and glxinfo's two libGL errors have dissappeared. But it still is confused about i915 - i965 driver, I wonder why. I have uninstalled Steam, all i386 packages and the whole architecture, leaving only 64 bit packages. I have found a strange line in /var/log/Xorg.0.log

[     7.264] xf86EnableIO: failed to enable I/O ports 0000-03ff (Operation not permitted)

You can find the complete log file here.

I have really no idea how to solve that.

But according to:

it might have to do with some missing files.
this command could potentially solve it:

sudo apt install ubuntu-mate-desktop
sudo ubuntu-drivers install

Besides that one error, everything seems to be ok.
According your log, the modesetting driver seems to be loading now. You can check again with inxi -G

1 Like