My MATE can't boot up no more!

Oops, I was annoyed by the fact that my number-pad wasn’t activated at login in screen so I followed a post explaining how to activate number pad a each boot, so I did :

sudo apt-get install numlockx
gksudo pluma /etc/lightdm/lightdm.conf
Then add this line to file lightdm.conf
greeter-setup-script=/usr/bin/numlockx on

Now my MATE doesn’t start, freezes on boot with dots flashing on and on…

Shoot !
I did a :
sudo remove numlockx
From restore mode but still stuck at booting !

Sent from my smartphone :frowning:

Did that command work?

I’d drop into root from the recovery menu, and then try this:

mount -o remount,rw /

This is so the root filesystem becomes writable (it’s mounted read-only by default)

apt remove numlockx


dpkg-reconfigure lightdm



1 Like

I just tried all that but it didn’t work out…
Dots when booting keep flashing forever !

You shouldn’t run terminal commands (or, god forbid, copy-paste) without first reading the docs to find out what they do and if they are a good idea. Even if that means (shudder) reading the man pages. I’ve seen countless “guides” online that either show you a hopelessly outdated way to do something, or were a bad idea in the first place. And that is if you don’t run into some troll who tells you to run rm -rf / --no-preserve-root . Just don’t do it, m’kay?

We may be running Ubuntu and not Debian, but 90% of this advice holds true on any system:

It looks like you installed the package numlockx and then edited one of your config files, if I were you I’d first try to restore your /etc/ file to its original configuration. I don’t think removing numlockx will help. Your computer will still be searching, in vain, for numlockx on bootup, which I’d guess would leave your computer still locking up.

It looks like ouromov’s dpkg-reconfigure lightdm command is intended to restore that config file. I don’t know why it didn’t work though. You didn’t keep a backup of your config file, did you? That would give you a chance to restore it. I’d try deleting the line you added or (preferably) generating a fresh new one.

If that still doesn’t work, maybe reinstall? That’ll be a real bummer unless you have backed yourself up before this.

BTW—I found this for enabling the numpad for 17.04: Looks like it might have been unnecessary to mess with lightdm.

I think I really messed up !

First, I deleted numlockx thinking that would help to boot up smooth
apt-get remove numlockx (from restore mode as root)
But you’re right now the system may be searching for numlockx
That would be why the flashing dots keep running on and on…

I tried to re-install numlockx with :
apt-get install numlockx
But being in restore mode with command line I think I have no access to internet through apt-get

As to the lightdm.conf file it was empty in the beginning and I just added a line :
greeter-setup-script=/usr/bin/numlockx on
I opened it with joe so as to delete that line but I was in read-only mode…

Am I gonna have to re-install MATE ???

Well, I’m no Ubuntu guru, but I think this is your problem. You need to restore your original config file, whether that means manually deleting it or regenerating lightdm’s configuration like ouromov suggests (actually, that sounds like the better option). Perhaps his command failed because you were not in read-write mode.

Unfortunately (or rather fortunately?) I’ve never used Ubuntu’s recovery mode so I can’t help much here. This is about the time I’d be checking the documentation:

This states the root partition is mounted read-only by default, this is probably your problem. I’d follow these instructions to get into read-write mode, then try running the commands ouroumov suggested again.

If you end up having to reinstall and you haven’t backed up your files before, you may still be able to save your files. Even with your installation borked, you can still boot up an UM live USB (like you used to install with). You can back up your files and reinstall from the live CD.

First boot the live CD, then back up your files. Click “try Mate”, open up the file manager, and access the files on your system drive. From here you can attack some kind of external storage and back up everything important.

Then you can try reinstalling UM without losing your home folder. Follow these instructions: Basically click through the prompts as normal until you reach the “Installation type” menu, then select “Reinstall” or “Upgrade” (the options available will depend on whether the live CD is a newer version of UM or the same as the system you are trying to rescue). Basically it reinstalls or upgrades your system in place, trying to preserve your home folder. You should still back up your important stuff first.

If that still doesn’t work, then reinstall again, this time selecting “erase and reinstall”. At least you’ll still have your files!

I tried everything again as mentioned above but the problem remains the same, my commands don’t return any error so it looks like it does its job but still… on boot, white and green dots flashing forever…
Nevermind, I guess I’ll have to re-install Ubuntu MATE
Next time I’ll think it twice before typing in the terminal until I understand every single digit typed.
Thanks guys, I learned something again !

Sorry for the really late reply. Did my suggestions regarding the live CD help you save your important files at least?

Yes, never ever run a terminal command until you understand exactly what it does. I find that the man pages can help here—typing man foo will return a terse but useful manual page on the command foo in the terminal. Try typing man man. :smiley: