N: See apt-secure(8) manpage for repository creation and user configuration details

I’m updating my ubuntu but it can’t update. This is the following problem attached in my terminal. Please help me to solve this problem.

Hi @rolandz9
Can you please give the full log when you run it in the terminal?
You can copy from the terminal using CTRL+SHIFT+C
Cheers

As said, please post the terminal output. A manpage reference is not very useful, the error code is :slight_smile:

That said, it sounds like your missing some keys. We will know for sure when you post the code. On the off chance I am right, run these lines in terminal (one line at a time).

sudo apt clean
cd /var/lib/apt 
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt update 

And welcome to our forums :grinning:

[email protected]:~$ sudo apt-get update
[sudo] password for ubuntu: 
Hit:1 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu xenial InRelease
Ign:2 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial InRelease
Hit:3 http://ppa.launchpad.net/longsleep/ubuntu-pine64-flavour-makers/ubuntu xenial InRelease
Ign:4 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial InRelease
Ign:5 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial Release
Ign:6 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial Release
Ign:7 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main arm64 Packages
Hit:8 http://ports.ubuntu.com xenial InRelease
Ign:9 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main armhf Packages
Hit:10 http://ports.ubuntu.com xenial-updates InRelease                 
Ign:11 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main all Packages
Hit:12 http://ports.ubuntu.com xenial-security InRelease                  
Hit:13 http://ports.ubuntu.com xenial-backports InRelease                 
Ign:14 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main Translation-en
Ign:15 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main arm64 Packages
Ign:16 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main armhf Packages
Ign:17 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main all Packages
Ign:18 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main Translation-en
Ign:7 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main arm64 Packages
Ign:9 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main armhf Packages
Ign:11 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main Translation-en
Ign:15 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main arm64 Packages
Ign:16 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main armhf Packages
Ign:17 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main all Packages
Ign:18 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main Translation-en
Ign:7 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main arm64 Packages
Ign:9 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main armhf Packages
Ign:11 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main Translation-en
Ign:15 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main arm64 Packages
Ign:16 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main armhf Packages
Ign:17 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main all Packages
Ign:18 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main Translation-en
Ign:7 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main arm64 Packages
Ign:9 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main armhf Packages
Ign:11 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main Translation-en
Ign:15 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main arm64 Packages
Ign:16 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main armhf Packages
Ign:17 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main all Packages
Ign:18 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main Translation-en
Ign:7 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main arm64 Packages
Ign:9 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main armhf Packages
Ign:11 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main Translation-en
Ign:15 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main arm64 Packages
Ign:16 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main armhf Packages
Ign:17 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main all Packages
Ign:18 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main Translation-en
Err:7 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main arm64 Packages
  404  Not Found
Ign:9 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main armhf Packages
Ign:11 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main all Packages
Ign:14 http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial/main Translation-en
Err:15 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main arm64 Packages
  404  Not Found
Ign:16 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main armhf Packages
Ign:17 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main all Packages
Ign:18 http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial/main Translation-en
Reading package lists... Done
W: The repository 'http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: The repository 'http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu xenial Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found
E: Failed to fetch http://ppa.launchpad.net/noobslab/ppa-gimp/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

your solution doesn't work, Iam getting same error.

Welcome to the forums.

What is the exact error you are getting?

What solution did you try?

Iam getting same error:
N: See apt-secure(8) manpage for repository creation and user configuration details

remove sources .list and index.html in /etc/apt dir

# cp /etc/apt/preferences.d/index.html /tmp
# rm -rf /etc/apt/preferences.d/index.html
#cp /etc/apt/sources.list  /tmp
# rm -rf sources.list

     then reboot

This will help us understand what in your sources.list is having issues.

apt-get update
Err:1 http://ftp.harukasan.org/kali kali-rolling InRelease
The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository
Reading package lists... Done
W: GPG error: http://ftp.harukasan.org/kali kali-rolling InRelease: The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository

N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

It looks like you are running Kali not Ubuntu MATE

You will probably find more specific support at the Kali forums

However, the error you are having looks to be an improper gpg key that you would need to update to the correct one that Kali uses to sign their packages.

Good luck

N: Ignoring file 'apt.strace' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: The repository 'http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Kindly,, i face this Error with Bash - Windows 10
could u please assist

please i'm having this same issue
i need help

please i having an issue with my ubuntu.

See apt-secure(8) manpage for repository creation and user configuration details.
W: GPG error: http://ftp.us.debian.org/debian stretch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 7638D0442B90D010 NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY EF0F382A1A7B6500
E: The repository 'http://ftp.us.debian.org/debian stretch Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
[email protected]:~$

what should i do?4

See post's #2 and #3 and follow those steps.

i have same issue and followed steps but still having issue