Nautilus [files] failed to launch

Just performed my daily apt update, upgrade and discovered that Nautilus failed to launch, however Caja works.
I hope this is temporary because I prefer Nautilus

Hi pfeiffep

Launch nautilus from terminal, see if it gives any errors.

Thanks, I did launch from terminal, didn't pay attention since it failed to launch ... just did another ..

(nautilus:12021): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
(nautilus:12021): GLib-GIO-CRITICAL **: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
Could not register the application: Timeout was reached
(nautilus:12021): Gtk-CRITICAL **: gtk_icon_theme_get_for_screen: assertion 'GDK_IS_SCREEN (screen)' failed
(nautilus:12021): GLib-GObject-WARNING **: invalid (NULL) pointer instance
(nautilus:12021): GLib-GObject-CRITICAL **: g_signal_connect_object: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

Synaptic does not provide the option to reinstall [greyed out] - gksudo nautilus launches it just fine

To complete the data gathering I executed gksudo caja - error produced

pfeiffep@Dell-1749:~$ gksudo caja
Initializing caja-main-menu extension
Initializing caja-open-terminal extension

--- Hash table keys for warning below:
--> l2054
--> inode/directory
--> root
sys:1: PyGIWarning: Caja was imported without specifying a version first. Use gi.require_version('Caja', '2.0') before import to ensure that the right version gets loaded.
** Message: Initializing gksu extension...
sys:1: Warning: /build/glib2.0-VLj5wM/glib2.0-2.48.0/./gobject/gsignal.c:2635: instance '0x55ebaabe1c40' has no handler with id '2864'
sys:1: Warning: /build/glib2.0-VLj5wM/glib2.0-2.48.0/./gobject/gsignal.c:2635: instance '0x55ebaaa95880' has no handler with id '2928'
sys:1: Warning: /build/glib2.0-VLj5wM/glib2.0-2.48.0/./gobject/gsignal.c:2635: instance '0x55ebaaa77220' has no handler with id '2935'
sys:1: Warning: Source ID 61 was not found when attempting to remove it
sys:1: Warning: Source ID 62 was not found when attempting to remove it

(caja:7689): Eel-WARNING **: "unique eel_ref_str" hash table still has 3 elements at quit time (keys above)

(caja:7689): Eel-WARNING **: "caja-directory.c: directories" hash table still has 1 element at quit time

Hi pfeiffep,

Unless Caja is misbehaving, you can safely ignore those errors. Often when libraries change (update) before the app developers get a chance to see what’s different, you can get odd errors. As long as Caja isn’t doing anything it’s not supposed to, it’s not something to worry about.

I don’t have or use Nautilus, but going by the errors and the fact it works under gksudo, my guess is a library update is conflicting with either something in your Nautilus settings, or possibly it’s cache (if it has one). You can test if that’s the problem by finding Nautilus’ configuration folder and moving it. It’s probably in your ~/.config folder, but if not you may have to hunt a little for it. Don’t delete it, just move it somewhere else, like your ~/Documents folder, for the time being. Log out, then back in and try to start Nautilus again.

Generally, the reason apps run under sudo when they don’t for a user is because most users don’t do any configuration for the sudo (root) account. So the app opens with it’s default settings. If Nautilus does work for your user, then delete the old config folder and reset any settings you had.

Thanks for the reply @folcred - I noticed that nautilus was available in user preferences as an alternative to caja.
I prefer nautilus because I’m familar with it since my original venture into linux was Ubuntu 12.

These symptoms were evident after my daily update / upgrade. I have been using nautilus in UM 16 for about 20 days.

1 Like

Have you tried cleaning the cache

Code:
sudo apt clean && sudo apt update

and purging nautilus?

Code:
sudo apt purge nautilus && sudo apt install nautilus

This will not alter your (Home) nautilus configuration file.

1 Like

Thank you @anon42388993. I have learned something about apt today! This solved the problem, now nautilus launched from command line and closes without errors. I’ll be keeping apt clean in my bag of tricks!.
Regards,
Pete

ps - I’ll keep my eye on this after my daily updates.

A handy link to a bag of tricks.

https://help.ubuntu.com/community/AptGet/Howto#Maintenance_commands

Maintenance commands are also located in the welcome center>software>last tab

:wave:

Thanks again @anon42388993, I think this “problem” is intermittent; after I posted my edit I chose files as my default file manager then went about my normal routine. When I opened files I clicked on the icon smb in order to reveal the contents of my NAS. After I closed the window files failed to launch once again [same errors when launching in terminal]. I switched back to caja and went about my business with the idea I would capture data when duplicating [as closely as I remembered] the steps; finished what I was doing and shut down… Well the best laid plans of mice and men … nautilus worked perfectly after I started up again.

Regards,
Pete

ps - apparently this has affected others in linux communities

Yes, others are affected.

Could Nemo be used as a work-a-round? Its like the old nautilus, I think you would like it.

This is just me not wanting to change :smirk:
Since caja doesn’t seem to have a problem, I’ll just adapt if files continues to be problematic after 16 official release.

Since this is a discussion and not a plea for help to mend a broken system I’m hoping that @anon42388993 or some other learned poster can help my unscramble the results below:
pfeiffep@Dell-1749:~$ apt-cache depends nautilus | grep Breaks
Breaks: gnome-bluetooth
Breaks: gnome-session
Breaks: gnome-volume-manager
Breaks: nautilus-sendto-empathy
Breaks: rhythmbox
pfeiffep@Dell-1749:~$ apt-cache depends caja | grep Breaks
Breaks: libcaja-extension
Breaks: mate-session-manager

Apparently both nautilus and caja, if uninstalled, will break something in UM 16 ???

Just an note

I get the same breakage with nautilus, but with nemo I get nothing and I run 16o4.

1 Like