Need assistance with Blender

Install Blender on Mate 22.04. There are no names on the buttons but only faded bluish patterns. Reinstall the program couple of times even last time did it manually using terminal. It is still the same.
Just wondering if anybody encounter this problem and maybe have a solution?

Thank you very much.
P.S. I am new to Linux

1 Like

Welcome @newtolinux to the community!

1 Like

Hi for a quick try you can go to:


Then download will show button for 3.6.4 LTS, click and a window will pop up to let you choose location. For initial ease click on Desktop.
Then on Desktop (or download location you choose) follow image.

Don't remember the exact wording but it may offer to use settings from an existing installation. If you choose ok or yes or whatever it will create a 3.6.4 profile using settings such as size and other features you were using in your existing. Might not see a version and it will start with a blank profile.

I have four different versions and either use a launcher or double click on folder to launch the version. Mine shown at bottom. Toolbars may be different than initial as using my profile picked up from another 3.6.x version on my system.

Possible may be a driver issue but seems like the rest are working for you.
The one in the repository is a bit old (you didn't mention how you installed)

P.S. in download you can ignore the donation screen


Thank you very much!
I newly install Ubuntu Mate and install Blender.
Blender installed several times after removing previous installation from app store and then using terminal. However it was the same result.
Will try your suggestion and report later on this week.