Netmask 24 issue

Would anyone have a fix for the netmask reverting to 24 when setting up static IP…

Please give more information on what you’re trying to do, and how you’re going about it.

Going into edit connections, add, wireless or wired same outcome,,, enter to save, exit come back in, netmask now says 24. Tried on laptop & desktop same outcome is technically a netmask of 24 bits.
Have you checked if your connection works while it says 24 here?

1 Like

It does work, am I confused here? It always used to say after edit, has something changed?

Entirely possible. Sorry but it’s been a while since I used static addressing and I can’t test right now.
Maybe you can grep the changelog of network settings to see when the change happened?

Guess I should run ifconfig see what it says…

Hi @smartnoise. I ran into this, too. If you’re like me, it’s silly to run DHCP on non-portables.

As @ouroumov points out, the CIDR format is equivalent to your example.

It looks like the applet still accepts netmask format but displays in CIDR (or a reasonable facsimile of it) . I’m sure it’s because IPv6 doesn’t ever want to see that old netmask format. :slight_smile:

1 Like

Agreed, I am networking desktops for sharing so static it is, mind you I have done it with several fairly static laptops also, good to know that 24 is my 255. equivalent, odd that it only started 16.04…
As far as IPv6, I have that set to ignore, based on my IT guys recommendation, so just using IPv4
One by one chipping away at frustrating Ubuntu bugs, love the MATE OS, don’t want to drop back to 14.04 but that would not be the worst scenario, compared to switching distros.
Now if I could just get the asus-pce-n53 wireless card to work under 16.04…another story

Sounds like we’re in the same boat. I’ve been watching IPv6 starting to accelerate but in no hurry at the moment, either. Heck, I just discovered yesterday how enp3s0 replaces good-old eth0, too. :rage:

CIDR format has been around a long time in IPv4 and I’m surprised you’ve not run into it. Good luck on the wireless card!

@Bill_MI: you know that won’t always be ‘enp3s0’, that’s hardware-dependant but will remain static on given hardware through multiple OS versions, even if you add / remove NICs.

@smartnoise: please mark the thread as resolved using the checkbox next to one of the posts.


Thanks all, for the advice & support!!