Network icon (and bluetooth icon) does not show up after upgrade from 18.04 to 20.04

I recently upgraded and had a few issues that I did not find solutions to online, but was able to eventually workout, I thought I would share.

My issue was after the upgrade, I did not see the network icon and could not connect to the internet. I was able to see that nm-applet was already running - and running nm-applet did nothing. I was able to manually run sudo nm-applet and connect that way, but it was fragile (couldn't run nm-applet & it seemed I needed to keep a terminal window open, nohup did work sometimes)

One thing I tried that felt important was the following:

  • Upgraded to the latest version of network manager & network-manager-gnome (sudo apt update && sudo apt upgrade to just update everything)
  • See what version was installed (sudo apt show network-manager and sudo apt show network manager-gnome)
  • Capture all your current settings. I took screenshots.
  • Download the packages online. I didn't find my versions on the ubuntu page, but did find them on which provided a download link on the ubuntu server, which I felt I could trust.
  • sudo apt purge network-manager-gnome and sudo apt puge network-manager Watch what is uninstalled, I also "lost" network-manager-openvpn-gnome for example.
  • Reinstall sudo apt install network-manager-gnome
  • Reinstall other "lost" packages

This helped, but did not solve the problem all the way. It seemed to make things more stable. I also had to reset the panels. I believe the topbar panel was running some old config that was broken.

So I ran mate-panel --replace

I also preferred the "Traditional" panel setup that I thought was the default on 18.04, so I went to settings, mate tweak, then set panels to traditional.

During my debugging, I also deleted or edited ~/.config/autostart/nm-applet.desktop and /etc/xdg/autostart/nm-applet.desktop (also copies for the root user and the blueman copies). In my working setup, my ~/.config nm-applet file exists, but is empty and my copy in etc is the following:

  [Desktop Entry]
  Comment=Manage your network connections

I had some other issues - my application icons were gone and time was missing, but I am going to make separate posts for that.

Welcome to the forum, @claw! :wave: :ubuntu_mate:

When you go to post explanations of what you did to make your system work like you wanted it to, I'd suggest you make your posts not under the "Support & Help Requests" category like you did here, but rather under the "Tips, Tricks & Tutorials" section:

Putting your lists of post-upgrade tweaks under that category keeps the forum clean and tidy; we don't want a forum which has misplaced topics. :mag_right: :question: :man_shrugging: Another benefit is that the first post of each topic created under that category is made into a "wiki" post; this allows relatively unprivileged forum-goers to edit your tutorials for grammar, technical accuracy and other such mistakes and missed opportunities. (Normally, only a moderator or the original poster of the topic can edit the first post; in the latter case, there is a time limit after which you may not edit even your own posts anymore, at least at low privilege levels.)

Furthermore, since this topic is currently in the Support & Help Requests section, may I ask you if you rebooted after the upgrade? Because if not, then you should have. A lot of things won't work correctly until you've rebooted.

Thanks, I moved it over