New install of 24.04 Will Not Boot

When fresh install of 24.04 finishes its restart boots perfectly, but when that's turned of it will not boot again. Install is on new Dell XPS 8960 with 1TB ssd and 64 gb memory. Have done this 3 times with same result.

Please see boot-repair report at Ubuntu Pastebin

Any help will be greatly appreciated.


1 Like

Welcome @mjy to the community!

there seems to be an issue with the usb stick (sda) line 33.

Grub should be written to the 1st partition of the nvme but it did not.

So when you reboot (without the sda) what screen do you get?


First I get a whitish screen briefly, then a black screen briefly, then a whitish screen that just stays forever.

maybe boot again from the usb stick and ask boot-repair to repair. It should write grub to the proper partition. Reboot (without the sda), if you still get the white screen, I suggest clean reinstall.

1 Like

pavlos_kairis, thanks for considering my post.

boot_repair advanced offers options for installing/reinstalling grub. Do you think that any of these options will fix my problem?

Sorry, I'm a bit of a newbie and didn't read your post properly. I'll do as you suggested and if that doesn't work I'll redownload the 24.04 iso and verify it and write it to a fresh usb and do a clean reinstall.

Thanks again for the fast reply and I hope I can mark this topic as solved.

Did the DELL XPS come with windows 10/11?

maybe you need to wipe the nvme completely and then do the install.

1 Like

The xps did come with windows and I think it was wiped out by the install of 24.04.
The boot-repair fix to install grub improved things. Now when I boot holding down the shift key I get the grub boot menu. But when I select ubuntu on that menu it goes off to 'Loading initial ramdisk' and hangs there. If I select Ubuntu recovery there it loads what looks like a full version, but still won't restart. I'm very puzzled.

How would I wipe the nvme? I noticed that boot-repair finished with a message to 'make your UEFI firmware boot on the Ubuntu 24.04 entry.' I don't know what it needs me to do there.

Have you disabled intel RST in the BIOS?

boot from the usb stick. If you have network, you can sudo apt install gparted.

This is a tool that allows you to wipe out disks among other things. On the top right, select the nvme, it will also show the sda. You need to delete whatever partitions are there so that the nvme has nothing, no partitions, just raw disk. Then, you can install ubuntu mate 24.04

(ADMIN: I tried to paste a screenshot, I got a msg "file should be up to 4MB", my file was 1.1MB but it would not paste it.)

1 Like

Thanks. Used gparted to remove all nvme partitions. Am reinstalling.

Full new install after nvme wipe and now back to blank screens and shift held down during boot not finding grub menu. Am going to do another boot-repair report after giving this a rest.

Putting linux on a new windows machine didn't used to be this complicated.

According to your posted logs, the problem seems to be that both your /dev/nvme and your /dev/sda are set to bootable which makes it a sort of russian roulette which one will win (and it seems that the sda device is constantly winning)

You must either make the sda device unbootable by removing grub from /dev/sda or force the UEFI-BIOS to boot from the nvme drive (or disable the possibility to boot from /dev/sda in UEFI-BIOS itself).


Here's a fuller statement of my problem.
I've just bought a new Dell XPS 8960 with 1TB nvram and 64 GB memory.
Dell website for this model offers a BIOS update marked as 'crucial'
and I verified and installed this (XPS8960_2.50_x64.exe) successfully.

Then I verified and installed ubuntu-24.04-desktop-amd64.iso. This
seems to install successfully. The installation ends by offering a
button marked 'Restart'. When I press this button I get a screen
telling me to remove the installation media and press 'ENTER'. When I
take out the USB stick and press 'ENTER' the machine boots up into
Ubuntu Mate which seems fine, but from previous attempts to install I
know that if I exit this the system will not boot again.

So at this point I downloaded, verified and ran boot-repair and
generated this newer boot-repair report Ubuntu Pastebin. I did not do the offered boot repair because I thought it better to ask for some expert advice first. I have not edited or shortened the report in any way because I don't think I have the expertise to do this helpfully.

I'm mystified because the new Ubuntu seems to be there but the machine
can't seem to find it to boot to. At this point I'm starting to worry that I have an expensive boat anchor.

The boot repair report states there is no bootloader (line 5).

There is a section in this page how to set the BIOS, please verify that your settings are as shown.
(UEFI, enable Legacy, secure boot disabled.)

Boot off the live usb, run gparted, select nvme0n1. It shows 2 partitions, select the first one and look at the flags, it should have boot, esp. If not, enable them, tell gparted to do it. Then reboot.

example: my disk is sda


pavlos_kairis thanks for reply. Please bear with my cluelessness in this area.

In BIOS my boot method is set to UEFI and my secure boot is turned off.

nvme0n1p1 is fat32 mounted at /boot/efi with 8.24 MB used and shows boot and esp flags.

Unfortunately the BIOS pages on my new Dell are different from the one in the picture you show and do not show 'enable legacy'.
The Dell support page you've linked to states that "NOTE: Be Aware the latest generation of Dell computers has dropped Legacy support from their BIOS."

So is the 'enable legacy' needed? And will it prevent booting? And do you think that the boot-repair message "locked nvram detected" is something that I need to deal with?

Since I understand to little of what I'm doing here I' going to wait for your reply before rebooting.

Thanks again for your patience.

Your boot partition has the correct flags but is calling a different bootloader and it fails. See line 46, it should be calling grubx64.efi (not shim) For Ubuntu, the pathname is \EFI\Ubuntu\grubx64.efi
(shimx64.efi is for secure boot).

You may have to create another boot entry. Play with the BIOS settings and tell it to use the ubuntu path I wrote above. Also, you have network boot enabled for ipv4 and ipv6, you dont need them.


Had a similar issue. Reverted back to "22.04" as a solution.

I could boot off of Kernel 6.5.0-28-generic, but not off of 6.5.0-31-generic. I think it did boot but there seemed to be no display driver installed for my AMD gpu

1 Like