New install, Wifi not coming up after initial updates

Just installed Ubuntu Mate 20.04 on Toshiba Satellite laptop. System installed, rebooted, ran the updates which ran ok over Wifi, but then Wifi not running. Tried my usual diagnostics - ifconfig, netstat, but it said to install net-tools, but with no Wifi nothing works. Tried deleting network connection and re-entering it, but no sign of a connection. Help please! Bill

Does lsusb find the wifi card? if so, post that line to look for a device driver.

Lsusb just lists the hubs and my mouse dongle,
It's not a USB card. lspci says: Realtek RTL8723AE PCIe Wireless Network Adapter.

And the Wifi was clearly working following the initial reboot otherwise it could not have run the updates.

As root,

echo "options rtl8723ae msi=1"  >  /etc/modprobe.d/rtl8723ae.conf

and reboot

OK, mild panic after reboot - opened terminal window and started to type a ping command, and it frose for a few seconds, then acted as if the '.' key was stuck down. The mouse cursor vanished, and the only
way I could recover was to power off. However, after a reboot it came up and it seems to be OK.

Can you explain what the option does, and why it should be needed when it was working before the updates?

I looked online for that chipset and linux driver, a post suggested adding the option msi=1. I suspect before the updates, it did modprobe on the fly and added that option. Upon reboot, that option was gone and wifi stopped working. Since this option is now permanent in /etc/modprobe.d/ you should not have any issues.

1 Like

modinfo rtl8723ae will give you a list of the parms this module uses ...

Hello, I have a similar problem, I have a notebok, Compac CQ50-112BR, used windows 7 and the wireless network worked on it. When I migrated to Linux, it only worked once on the Linux Mint distro, after that it stopped, I tried other distros and nothing, thinking that this would be it, now I use ubuntu Mate, the wi fi network card is model AR542x Wireless Network Adapter (PCI -Express). Please, I've looked in many places and I can't find it, I await a solution for those who know.

the chipset AR542x should work with the ath5k module. Do a modinfo ath5k, you will see a no_hw_rfkill_switch parameter. Pass that with value 1 to the /etc/modprobe.d/ath5k module and test.

Can you boot into your old kernel and will WIFI then work? I have had twice since using Ubuntu Mate where the new kernel did not support my Broadcom WIFI. The next kernel did, I just had to use an old kernel for a bit.

1 Like

@jymm that post was for Eduardo.

@pavlos_kairis Noble friend, I'm new to the linux world, I got to this editor, but I don't understand how to add what you asked for in your post. See the editor and draw your conclusions.

# This file lists those modules which we don't want to be loaded by
# alias expansion, usually so some other driver will be loaded for the
# device instead.

# evbug is a debug tool that should be loaded explicitly
blacklist evbug

# these drivers are very simple, the HID drivers are usually preferred
blacklist usbmouse
blacklist usbkbd

# replaced by e100
blacklist eepro100

# replaced by tulip
blacklist de4x5

# causes no end of confusion by creating unexpected network interfaces
blacklist eth1394

# snd_intel8x0m can interfere with snd_intel8x0, doesn't seem to support much
# hardware on its own (Ubuntu bug #2011, #6810)
blacklist snd_intel8x0m

# Conflicts with dvb driver (which is better for handling this device)
blacklist snd_aw2

# replaced by p54pci
blacklist prism54

# replaced by b43 and ssb.
blacklist bcm43xx

# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist garmin_gps

# replaced by asus-laptop (Ubuntu: #184721)
blacklist asus_acpi

# low-quality, just noise when being used for sound playback, causes
# hangs at desktop session start (Ubuntu: #246969)
blacklist snd_pcsp

# ugly and loud noise, getting on everyone's nerves; this should be done by a
# nice pulseaudio bing (Ubuntu: #77010)
blacklist pcspkr

# EDAC driver for amd76x clashes with the agp driver preventing the aperture
# from being initialised (Ubuntu: #297750). Blacklist so that the driver
# continues to build and is installable for the few cases where its
# really needed.
blacklist amd76x_edac