New Raspberry PI 3B+ doesn't start Ubuntu (2020)

I have a problematic issue with Raspberry PI 3B+ used for a commercial product.
In 2020 I have developed an application running on Ubuntu_Mate 20.04 and this product has worked fine till now.
Recently I have bought severl Raspberry from official distributor in Italy and I have discovered that my application doesn't work anymore.
I have tried to install Ubuntu-Mate 20.04 and this doesn't install. The problem is related with this old version of Ubuntu. When I insert the microSD card in Raspbery the green led continue to blink periodically as a repetitive attempt to start but it can't start the installer.

Only Ubuntu-Mate 22.04 (released on december 2023) can be installed but my application is incompatible with this version of Ubuntu so my commercial product can't be produced. This is a big deal for my factory.

Can anyone suggest me why newer Raspberry can't start Ubuntu released on 2020? They have been ordered with the same part number so officially they are the same product.
Best regards

1 Like

Welcome @Lor75 to the community!

I don't know what the problem is, but I comment that, with the Pi 3 versions after 18.04 were too 'heavy' so I moved to Pi4 for my systems.

1 Like