New RPi3B+ install, ssh and vnc working - OK

hey folks - thought i'd pass on my experience today from a Mate install on a spare pi... here are the basic steps i followed:

  1. burned an sdhc of 32-bit armhf ubuntu-mate:


using the Raspberry Pi imager under OS X Catalina

  1. booted to install, configured following the prompts, wifi configured no problem
  2. turned off auto updates (i hate that this is enabled by default under Ubuntu)
  3. installed, checked, deleted and reinstalled openssh-server; the web page says to install it, but it was installed already! however, there was a key-gen issue: no keys, so doing the apt remove/install dance worked
  4. i recommend to not upgrade! found out to late that this is not recommended anyway for this release; can't remember where i read it... it caused problems with HDMI borders for the desktop, resulting in missing menus, panels for me
  5. installed a vncserver - this was a real pain in the ass initially for me as the default armhf mate release or repos do not have a server, so:
  6. added main ubuntu repository via software sources, then:

sudo apt install tigervnc-standalone-server

  1. created a .vnc/vnc.conf containing:

    $vncStartup = "/home/pi/.vnc/xstartup";
    $geometry = "1024x768";
    $localhost = "no";

  2. create an xstartup containing:

    #! /bin/sh
    [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
    [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
    xsetroot -solid grey
    vncconfig -iconic &
    x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
    x-window-manager &
    mate-session &

  3. voila!

hope this helps someone out there... i screwed around with archlinux for a whole day on an RPi4 - got it working, but the client i wanted doesn't want to run properly (no audio support right now under archlinux for the RPi4... and obviously no real Mate support for RPi4 (am not going to use 'Core' - sorry, ain't gonna happen...

tks to the developers for putting together a nice working Mate for RPi users!

on the Gulf of Mexico


hey folks - i know it's not 'de rigeur' to reply to one's own posts, but wanted to update on the install:

  • printing worked fine from the start: my Epson 3710 was immediately recognized and configured for wifi printing automagically - very nice (i remember having to download and build my own CUPS drivers for Raspbian and my old Epson Eco-tank directly from Japan - Epson likes GNU/Linux, btw)

  • installed gqrx-sdr, which now allows me to wirelessly stream FM radio, 2M, and NOAA WX via a cheap RTL dongle and gqrx's built-in UDP transport (simply specify the destination host and port [7355] in the pop-up Audio dialog)...

  • now i can control a remote SDR radio and listen on my boxen using vlc! for example, under OS X:

/Applications/ --demux=rawaud --rawaud-channels=1 --rawaud-samplerate=48000 udp://@:7355 &

(for GNU/Linux, simply substitute cvlc for the above command)

have a lot of fun!

on the Gulf of Mexico

A note for the future:
you don't need to delete/reinstall the SSH, merely
ssh-keygen -A
service ssh restart

and you'll have it usable!

tks! yep, i read that as a solution somewhere, but i'm lazy so... LOL!

gonna add this to my notes (i keep a running file on new installs of item 'fixes,' so i don't have to re-research the proper incantations - even though i can read man pages...

and the 'fiddling' on installs never seems to get done properly the first time... for example, in my vnc.conf listing above, i could have just stayed with Tigervnc's standard name, Xvnc-session or not even bothered to change the name to xstartup, as xstartup is recognized as a script by Tigervnc to begin with - ackpht!

also, i should have (and did) remove the xsetroot, vncconfig and x-terminal-emulator lines as unneeded...