No Audio On HDMI Or 3.5 Jack

software
system

#1

I’m Very Basic User Of This Operation System [ No Idea ] And Hers What I did In Last 7 Hours :-
I’ve just installed Ubuntu Mate On Raspberry PI3 from start i was facing problems

  1. Unable to update anything ( Low Disk Space Issue) Solved Via [ sudo raspi-config ] //Boot resize
  2. After Update Firefox decided not to work at all ! [ Solved Via Forced Previous Ver. Install So I’m Back In 1943 Now ]
  3. VLC didn’t update properly and I’m Not able to install with anything tried Everything.
  4. Kenel fails On Start [ Still Running Fine ]
  5. No Audio At All !!! Ive Forced It On HDMI And 3.5 But Still No Sound. However Sound Panel Shows Music Is Playing.
    Any Solution Will Help …
    And I Must Say You Guys Have Done Very Good Job On This I Really Like It. Perfect Desktop Simple But Powerful…

Thank You,
Karan [ India ]


#2

I assume you’ve got acquainted wth the file /boot/config.txt, where a lot of useful config stuff can be done.
I set to assume all video modes support audio (all modes), as well as forcing hdmi.
How are you connecting audio? The use of the audio/video jack can be a problem if you get the wrong cable type.
I cannot remember any other prolem areas.
Derek


#3

With the file /boot/config.txt ???

I Have no idea how to use it or what to do with it … can you be more specific about this settings …


#4

Please Help !!! Im Still Using Without Sound … :frowning: Is there any solution ???


#5

Try bumping the video memory/ system memory split. :wink:


#6

Just Did 64 To 128 Now… Still Nothing!!!


#7

Have you tried manually specifying your mode and resolution? Try using:

sudo raspi-config

and tinker with modes and resolutions. You might find one that works with sound. :wink:


#8

Its Working !!!i don’t know how but 3.5 Jack is working no HDMI … Still Thanks For Replying…


#9

/boot/config.txt is a text file which can be edited (NB it is root owned - I suggest you not ecit it if this isn’t understood).
In the file you can see the parameters which can be modified, together with comments ( in lines starting with the # symbol)
This file is consulted in the boot process.
I don’t see what you have achieved - both audio and video via HDMI?
-audio via 3.5 jack and video via HDMI?
or what?
What did you set with raspi-config?
Derek


#10

Yes Set All The Out To 3.5 Jack Via raspi-config and sound is coming only on 3.5 Jack !
their is one more problem i was facing is whenever i try to update using Software Updater error
Shows Up //Boot Have Not enough Space And Ask About 40MB More Free Space… I literally Have Not
Idea what to do …


#11

There was a thread some while back dealing with the out-of-space on the boot partition (and offering a way round: see [url=https://ubuntu-mate.community/t/disk-space-error-boot/12386] this thread and the one it links to {/url] )
Since this is a special distribution, I’m not sure that standard update methods for ubuntu are recommended.
I’ll have another look at my setup, which gets me sound on the HDMI channel (haven’t checked the jack output, as I don’t have a suitable lead readily to hand.
Derek_


#12

Later: I checked settings to be

  1. raspi-config sound auto
  2. sounds hardware BCM… output analog
    3 config.txt
    hdmi_force_hotplug=1
    hdmi_drive=2
    hdmi_force_edid_audio=1
    and also some which relate to my setup of monitor and connection cable
    sdtv_mode=2
    hdmi_group=2
    hdmi_mode=35

You can check your selected monitor modes from command line using:
tvservice -s
HTH
Derek


#13

Thanks I check that !!


#14

open terminal

For HDMI

sudo amixer cset numid=3 2

For 3.5mm audio jack

sudo amixer cset numid=3 1