'no bootable device' acer cloudbook 14

Hello, I recently nuked Windows 10 and am trying to get ubuntu-mate running.

I’m having trouble getting ubuntu-mate 18.04 booting on an Acer Aspire Cloudbook 14 A01-481 C8G8.

I’ve tried the instructions on https://askubuntu.com/questions/627416/acer-aspire-e15-will-not-dual-boot, https://askubuntu.com/questions/916223/no-bootable-device-on-aspire-one-series-ao1-431 and https://itsfoss.com/no-bootable-device-found-ubuntu/

When I try to add the EFI file to the database I get a message that says, “File Is Exist” and nothing more. I’ve tried erasing and resetting the UEFI settings and starting from scratch but I still get this message and it doesn’t seem that the file gets added. At any rate I simply cannot get this machine to boot up into ubuntu-mate. Any thoughts are appreciated.

For mine, I had to disable secure boot and switch from UEFI to Legacy in BIOS settings.

1 Like

If you have W10 dual boot you must deactivate Trusted Module Encryption (Bitlocker) if you have activate it, in some cases this activate itself, I think, starting in Aprils Update:
Powershell admin --> Disable-BitLocker -MountPoint “E:” (if E is the W10 partition)
Close W10 pressing shift Key all the time.
Maybe the problem is in your bios configuration. Try to find CSM option. Change it to Enabled. Secure boot disable, UEFI enabled. Other option is install Mate with SB enabled too, and when installed it you disable it in your bios menu.
Hope it helps you.

I ended up setting the BIOS to Legacy and disabling secure boot. Since I had a UEFI installation, I had to re-install so Linux was recognized but everything works great now.

I appreciate the advice from both of you thanks!