No Desktop after do-release-upgrade

I was running Ubuntu 18 and just now did the do-release-upgrade. I kept picking "Y" to install the maintainer's version of files assuming I could configure what was broken after it came up. It seemed to complete fine. I rebooted and it comes up, I can see the log messages, then the screen goes blank, but no desktop ever appears.

ssh is working and the contro-alt-F3 gets me to a prompt. I've tried all the various apt-get update, apt-get dust-upgrade, clean, auto remove, etc. that other topics suggest but it still doesn't give me a desktop.

My disks are not exported and they should be. I believe I had SMB set up because NFS wasn't stable when a Mac was a client (if I recall correctly). pi-hole seems to be up and working. That is about all that this critter is being used for.

This isn't a huge problem but I'm hoping it is something simple and worth the time to fix.

First of all you have to check that your current version is really 20.04 LTS.
Get the output of the following command:

cat /etc/os-release

it should include VERSION="Ubuntu 20.04.2 LTS (Focal Fossa)" line.

Then get list of all repositories by executing

grep -ir "deb" /etc/apt/ --include="*.list"

command. It will return long list of repositories including both enabled and disable during upgrade. It would be great if you upload the full output of pastebin.

Then install Aptitude by

sudo apt-get update
sudo apt-get install aptitude

Find locally installed packages by

sudo aptitude search ~o

and add output of the above command to next post.
Then reinstall Ubuntu MATE desktop task-package by

sudo apt reinstall ubuntu-mate-desktop^

and report any errors in next post.

1 Like

Thank you for your help. New pastebin

Note it is Ubuntu 20.04.3 (not 2)
ubuntu-mate-desktop is not installed (I don't know why)
I also have pi-hole installed which isn't showing up but it seems to be happy.

Should I just install ubuntu-moate-desktop and see what happens?

I found that aptitude does not work for tasks.

So you have to use sudo apt reinstall ubuntu-mate-desktop^ to reinstall MATE desktop if you really need it.

I did the sudo apt reinstall ubuntu-mate-desktop^ and rebooted. Same symptom.

I logged in and run top and found lightdm-gtk-greeter consuming 99% of the CPU so I removed it and all other lightdm packages that were installed. I had also installed x11vnc at release 18 which I thought might be conflicting so I removed all of the vnc packages I had installed. I then did the reinstall again and finally got a desktop logon.

If anyone wants me to do any post mortem data capture, please let me know. I'd be happy to help out.

Thank you for your help

IME, this problem - which seems to reoccur with remarkable consistency over the years - is ALWAYS lightdm screwing up somehow. About half the time, sudo dpkg-reconfigure lightdm tends to sort it out; and if that doesn't work, purging and reinstalling lightdm does.