No gigabit conection

networking

#1

Hi!

We have computers that have a network card and the connection is only 100 megabytes instead of 1 giga (they are connected to a giga switch)

This is the result of the lspci command

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 05)

ethtool command:

Settings for enp2s0:
	Supported ports: [ TP MII ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	Advertised pause frame use: Symmetric Receive-only
	Advertised auto-negotiation: Yes
	Link partner advertised link modes:  10baseT/Half 10baseT/Full 
	                                     100baseT/Half 100baseT/Full 
	Link partner advertised pause frame use: No
	Link partner advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: MII
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	Supports Wake-on: pumbg
	Wake-on: d
	Current message level: 0x00000033 (51)
			       drv probe ifdown ifup
	Link detected: yes

Thanks!


#2

Test/replace the Ethernet cable … I had to do that in some systems.


#3

Thanks for your answers but i I tried with a cat5e and cat6 cable and it’s still 100

Regards


#4

Can you try another card?

from what I read, the description on the card is misleading … either you have Fast Ethernet (100) or Gigabit (1000). And ethtool shows that you have 100 only. I assume the switch port it connects to, is orange instead of green.


#5

Hi,the swtich port are giga, if i connect my laptop its 1gb link

Regards


#6

my laptop has the same Realtek card (RTL8101) and ethtool shows only 100Mb. It’s a hardware issue, your device works at 100Mb, it cannot go to 1000. I connected my laptop to the gigabit switch, I still get 100Mb hence the orange color. Other devices on the same switch are green because they are capable of 1000Mb. Hope this helps.


#7

And why on windows the same hardware works at 1000?

Thanks


#8

TBH, it shouldn’t. I have the same chipset in my laptop and verified the same in both Windows and Linux. Realtek stuff is pretty generic and, in my experience, performs equally well, regardless of the OS.

If you really want to check, open the property sheet for your network card in Device Manager. Click the Advanced tab and select Speed & Duplex in the property field. Click the dropdown under Value and you’ll see all the options for your hardware (be sure not to change it). In my case, it matched the info given by ethtool.