No internet connection after fresh install 16.04

@ouroumov I dont remember. Let me try it again. I will report back.

Did it. Looks different now.

[    1.313084] alx 0000:03:00.0 enp3s0: renamed from eth0
[    4.144147] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[    4.144509] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[    4.259453] alx 0000:03:00.0 enp3s0: NIC Up: 1 Gbps Full
[    4.259716] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready

So far so good. This is such a unique problem.

1 Like

Hi. My solution was.
After the install 16.04 the ethernet not work.

ethtool enp4s0 said Link detected: no.

I did the following

1- remane, write NAME = eth0 into /etc/udev/rules.d/70-persistent-net.rules
sudo pluma /etc/udev/rules.d/70-persistent-net.rules

2-edit /etc/network/interfaces, like this.

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

3- and write this comand line into the /etc/rc.local
sudo pluma /etc/rc.local
ethtool -s enp4s0 autoneg off speed 100 duplex full

I think the problem is in the auto-negotiation. In my case if in off the ethernet work.
Before this check that the module is loaded. I was. the driver also. But only these three steps worked.


I just bump on this thread while looking for a solution for a similar issue.

My issue:

Quick question, are the above suggested solutions successfully worked? Are these also applicable to wireless connections?