No internet connection after fresh install 16.04

Did a fresh install and everything was fine. After a reboot I find there is no network connection at all. I rebooted again and it was there, then I rebooted after that and it wouldn’t connect again. Bringing the interface down and up seems to work, but I shouldn’t have to manually do this. Something is wrong. It didn’t do this on the prior version.

Hi @talormanda,

have you run a full system update?:

1 Like

Hi @wolfman

That is a very lengthy page. What are you referring to specifically? I checked for updates many times and it came up empty, and also ran “sudo apt-get update && sudo apt-get dist-upgrade”

I rebooted again after checking those things again and now my PC doesn’t ping. Is there a log anywhere that will tell me what’s preventing it from getting an active network connection? It doesn’t even ping on my internal network even though it says it has an IP address. I rebooted and it’s now working again. Still need to find the cause of this…

Hi @talormanda,

I'm afraid to say that there are several bugs in the new Ubuntu 16.04 and this may be one of them!, see this thread which I must hasten to add that I have not read through it myself yet!:

I don't know where you will find any logs sorry!. :confused:

@talormanda : is it a Wireless connection? Do you have multiple connections (Wired + Wireless) and if so are all of them affected?

@ouroumov This is a wired connection that was flawless under the prior version of MATE to 16.04. I do have wireless but I did not check it. I certainly will.

Hi @talormanda,

try changing your software sources download location and updating again as there are several problems with the repo’s not syncing or something like that!. this may well help you solve your problem.

Update guide is linked above!. :smiley:

Still having issues…Here is the boot log if it helps:

Thanks for the dmesg output. I see IOMMU stuff that I’ve heard cause a lot of problems in Linux.

Try adding/changing:


to “/etc/default/grub” and then run “sudo update-grub” and then reboot.


@Dave_Barnes Where do you change this?

Open Caja with the following command:

Press Alt + F2 and type:

gksudo caja

then open File System (on the left of Caja) > etc > default > grub and edit the file per @Dave_Barnes's tip!. Look at my pic below:

@Dave_Barnes It looks like mine was set to:


Can you explain what this is? Did this change from the previous version of ubuntu? Because my PC never had issues up until 16.04. I’m going to change it later and test when I’m home.

Previous Linux kernels used a DMA bounce buffer (ie. iommu=soft was default). Current Linux kernels use hardware iommu if available. Hardware iommu support exposes many new problems.

@Dave_Barnes So this was a change just added in 16.04? If so, why use it if there are so many problems? Ick.

The iommu change has nothing to do with Ubuntu. The change is in the Linux kernel. The iommu is set up by the PC BIOS and then managed by the Linux kernel. There are currently 63 bug reports containing iommu at These types of problems are very hard to find and fix. See

@Dave_Barnes Sorry. Not trying to be pushy, just want to know if there was something that changed going to 16.04 that made this issue arise?

@Dave_Barnes Some sad news. I did the change and the issue still persists. Here is the dmesg log:

What I got out of it:
Line 1101: [ 1.398961] alx 0000:03:00.0 enp3s0: renamed from eth0 Line 1320: [ 4.385627] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready Line 1321: [ 4.386149] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready Line 1322: [ 4.386917] alx 0000:03:00.0 enp3s0: NIC Up: 1 Gbps Full Line 1323: [ 4.387135] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready Line 1345: [ 14.976666] NETDEV WATCHDOG: enp3s0 (alx): transmit queue 0 timed out Line 1379: [ 20.082081] alx 0000:03:00.0 enp3s0: NIC Up: 1 Gbps Full Line 1384: [ 34.979203] alx 0000:03:00.0 enp3s0: NIC Up: 1 Gbps Full Line 1385: [ 74.981457] alx 0000:03:00.0 enp3s0: NIC Up: 1 Gbps Full

The above says setting IPv6 to “ignore” fixes the issue…but why would that cause this? and what issues do I have turning that to ignore?

From your dmesg log:

Command line: BOOT_IMAGE=/boot/vmlinuz-4.4.0-21-generic root=UUID=d8f6d76b-4d0c-4b60-b4ed-83fde031d9dc ro quiet splash vt.handoff=7

I don’t see iommu=soft.

Did you paste the correct dmesg log?

1 Like

I did. I will try to play around with it again after work and see, but that is definitely the file and I did have it added because I just checked.

And did you run “sudo update-grub” after doing that?

1 Like