No more web access only with some applications

Good evening,

Following an argument between my children or the keyboard found on their way mad... Some applications no longer have access to the internet, even though the network is working.

For example, Firefox can no longer access internal while the Tor browser can.
Impossilbe to update repositories, because the download of repository information failed...

I'm on Ubuntu Mat 22.04.

Does anyone have any ideas?
In advance, thank you

Translated with (free version)

Yes, they probably accidentially sabotaged your network settings.
In your case it should look like this:

To reach this menu:
click the networkicon in the panel
click 'edit connections'
click 'wired connection'
click the cogwheel
select the tab IPv4 settings
(you might want to have the same in the tab IPv6 settings)

1 Like

Thank you for your feedback. the network setting seem correct :

I don't understand why only the tor browser allows to browse the internet and all the other applications to browse, update packages, etc. don't have access to the internet... ?????

Then, I did a ping test on google server and also on quad9 server which works. However when I try to ping, I get a temporary failure return in the name resolution.
so I don't know if it's a clue, because I don't know much about how computer networks work...

Thanks for your help

Hi @Alexdici :slight_smile:

If you want to use, as your DNS Servers, the one from Google ( and the one from Quad9 (, I suggest that you, in that same network setting window that you showed in the screenshot of your post ("Modification de Connexion Ethernet 2" - "Paramètres IPv4" tab), do the following:

1 - Change the selected value in the "Method" ("MĂ©thode") dropdown list from "Automatic (DHCP)" ("Automatique (DHCP)") to "Automatic (DHCP) addresses only" (I don't know what is the French translation but it should be the second option in that "MĂ©thode" dropdown list).

2 - In that same window, add the Google and Quad9 IP addresses of their DNS Servers in the "Serveurs DNS supplémentaires" ("Additional DNS Servers") text box (which will have its description changed to "Serveurs DNS" / "DNS Servers" by then):,

3 - Also in that same window, click on the "Enregistrer" button (in the lower right corner) to save your changes.

I hope that helps. Please reply later to say if doing that solved your issue (or not) :slight_smile:


Hi @ricmarques ,

Thanks for the help.
The idea of pinging the google or quad9 dns server was just to test the connection.

Concerning my internet access problem, it has just been solved by a person on the french forum of unbuntu mat at this address :

Anyway, thanks again for your help
Have a nice day :wink: