No networks show up in my HP Pavilion dv6000

I installed the firmware-b43-installer and purged bcmwl-kernel-source. I can the “enable wifi” in the network menu but I couldn’t see my home network shown. Can someone verify my wifi is working or not?

THANKS FOR YOUR HELP

Chauncy

[email protected]:~$ uname -a
Linux dv600 4.13.0-36-generic #40~16.04.1-Ubuntu SMP Fri Feb 16 23:26:51 UTC 2018 i686 i686 i686 GNU/Linux
[email protected]:~$ sudo lshw -C network
[sudo] password for chauncy:
*-network
description: Network controller
product: BCM4311 802.11b/g WLAN
vendor: Broadcom Limited
physical id: 0
bus info: [email protected]:02:00.0
version: 01
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=b43-pci-bridge latency=0
resources: irq:16 memory:d8000000-d8003fff
*-network
description: Ethernet interface
product: 82573L Gigabit Ethernet Controller
vendor: Intel Corporation
physical id: 0
bus info: [email protected]:05:00.0
logical name: ens4
version: 00
serial: 00:1b:24:1c:4b:d6
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.5-1 ip=192.168.0.79 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:29 memory:da000000-da01ffff ioport:4000(size=32)
*-network DISABLED
description: Wireless interface
physical id: 1
logical name: wlan0
serial: 00:1a:73:3f:d8:0f
capabilities: ethernet physical wireless
configuration: broadcast=yes driver=b43 driverversion=4.13.0-36-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11
[email protected]:~$ iwconfig
ens4 no wireless extensions.

wlan0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on

lo no wireless extensions.

[email protected]:~$

*-network DISABLED
logical name: wlan0

Looks like your Wireless interface is disabled.

Open a terminal and try running

ifup wlan0

Thank you very much for the response. I tried but:

[email protected]:~$ ifup wlan0
Unknown interface wlan0
[email protected]:~$

Reboot your machine. Just installing firmware-b43-installer and purging bcmwl-kernel-source won’t activate your wireless without a reboot. Good luck @chauncyliu.

done all these. wifi is still disabled :frowning:

Hmmm, I did it again from the beginning and it works now. Thanks