No operating system found

Hello again,

I'm afraid it is not a ubuntu-mate specific problem, but let's give it a try here.


Error 1962: No operating system found.Press any key to repeat boot sequence.

I am installing Linux on an old machine (Lenovo ThinkCentre71 - Intel Pentium CPU G840 @ 2.80Ghz - 2Gb RAM

It was running Windows and some outdated linux distribution on dualboot and I wanted to get rid of the proprietary thing. I booted some Mint iso and got this error message: Error 1962: No operating system found.Press any key to repeat boot sequence.

Didn't bother for some time but here comes 2024, I've got a bit of time, let's sort that out. I used the same USB stick with the old Mint that I had. Noticed that it was creating two partitions, the first being a small EFI and the second an EXT4. So I went for one big EXT4 partitition instead (mounted on /) and boom it worked.

Could be the end of the story, but I got greedy. I figured that the performance wasn't that great (it was xfce Mint though) and went for ubuntu-mate instead. Since then, whatever I try, I only get that same error message about no operating system.

What I tried: normal install, one big EXT4 partition, one small EXT2 for Grub, one small FAT32 partition for Grub and all the variations I could think of while partitioning. Sometimes it says that Grub couldn't be installed (and that it is a fatal error), sometimes the installation goes through. Either way, no boot.

If someone has a suggestion, it will come in handy. I have obviously researched the issue and it is very likely an MBR vs EFI problem coming from the BIOS. What troubles me though is that it worked somehow with just one big partition and the old version of Mintxfce.


Hi Piko,

it is probably due to a (typical for lenovo) buggy UEFI implementation so you might have more success to run with the BIOS in compatibility mode (a.k.a. CSM or Legacy mode). That is, at least, what seems to be the common experience that other lenovo users have.

Read this:

And especially the second reply:

I had the same problem installing Linux Mint 17.1 (Ubuntu 14.04 base) on a Lenovo H430. I'm not sure why I didn't have any issues installing Linux Mint 15 on the same box a year-and-a-half ago, but I probably spent 10 hours trying to get Mint 17.1 to work. I tried ARR's own fix above, I followed steps outlined on several other web pages, I tried Boot-Repair. In the end, the ease of the fix was inversely proportional to the time I spent banging my head.

All I needed to do was to enable the Lenovo H430 CSM option (Compatibility Support Module) in the BIOS/UEFI (F1 on power up to enter UEFI). The other settings fell into place automatically. Then I rebooted and was actually a bit angry that it worked given the time I had invested on more complicated attempts at solving the problem. In the Startup tab of the UEFI my settings were

CSM [Enabled]
Boot Mode [Auto]
Boot Priority [Legacy first]
Quick Boot [Disabled or Enabled, either will work]
Rapid Boot [Disabled]
Boot Up Num-Lock Status [On] (shouldn't matter but included for completeness)
Keyboardless Operation [Enabled] (shouldn't matter but included for completeness)
I had made changes to Boot Mode and Boot Priority and Quick Boot several times in my attempts to get the new Linux install to boot. But without enabling CSM, nothing worked. If you have a Lenovo H430 and are having trouble installing Ubuntu or any other Linux, I would definitely recommend trying this setting. If you have a different computer but have a CSM option, this might work for you as well.

One of the replies is a one sentence conclusion:

This is the way! CSM -> Enabled solved my problem. Thank you! – kchan

I woud say, read the above mentioned thread and try things out :slight_smile:
good luck :+1:


Hello tkn,

Thank you for your answer.

While researching the issue I had read similar threads related to the "no operating system found" error from other Lenovo users.

The problem is that my BIOS doesn't give me the option to enable CSM. Besides the boot sequence configuration, the Startup menu only includes:

Quick Boot [Enabled or Disabled]
Boot Up Num-Lock Status [On or Off]
Keyboardless Operation [Enabled or Disabled]
Option Keys Display [Enabled or Disabled]
Option keys Display Style [Normal or Legacy]
Startup Device Menu Prompt [Enabled or Disabled]

I have tried enabling and disabling all these options, but to no avail.

Now, that would suggest that my best shot would be to upgrade the bios, which I am very reluctant to do because:

  • if I brick it, it's not good
  • I got it to boot somehow with that old Mint version, which suggests that is still possible with the current bios
1 Like

Considering you listed all your BIOS options I slowly get the idea that you computer must be from before the introduction of UEFI. I also checked the manual and no mention of UEFI whatsoever, so I guess that this is a classic (legacy) BIOS.

This usually means:

  1. Partition can only be MBR.
  2. Do not use a harddisk that exceeds 2TB.
  3. Don't create an EFI partition, it won't be used anyway.
  4. If the installer asks for where to put the GRUB bootloader, place it in MBR
    (make sure you install it on the harddisk you want to boot from and not somewhere else)

If (at all) possible, let the installer do the partitioning. Choose for the option to erase the whole disk and install Ubuntu-MATE 22.04

If the BIOS is (U)EFI capable then you should have an EFI partition and a GPT partition table (not MBR), otherwise it would not boot.

But, based on your information, there seems to be no (U)EFI so you have to use MBR (because GPT won't be recognized by legacy BIOS without some form of BIOS extention)

It is supposed to still work that way on legacy BIOS systems like the Lenovo ThinkCentre71. I will test on my old pre-UEFI laptops (one very old ASUS and one very old Lenovo E series)

EDIT: Now installing on my very old ASUS
Notebook: Asus F3T
Processor: AMD Turion 64 X2 TL-56
GPU: NVIDIA GeForce Go 7600 256 MB
Display: 15.40 inch, 16:10, 1280 x 800 pixels
Weight: 2.9kg

OK, here is the deal:

After install on my ASUS, which has a BIOS dated 2005, which predates both GPT and UEFI by several years, I ended up with:.
a GPT partitiontable (!?!), 1 GRUB partition, 1 EFI partition(!?!) and 1 EXT4 partition.
And it just ... works.

I suspect grub to do some magic here. See this:

Look at /dev/sda1:
grub2 core.img - 1MB - bios_grub

I suspect grub to support GPT and LVM on legacy BIOS this way. This is implemented probably somewhere after 20.04.
So this is the current situation: Ubuntu-MATE creates 3 partitions where:

  1. first partition: grub-core.img ( 1MB )
  2. second partition: EFI (512MB)
  3. all other stuff: (rest of the disk)

The first partition is needed because the current grub-core.img with GPT support needs space so this partition is created to "reserve space" for grub. It seems that this is not needed on an MBR device as long as grubcore fits in about 60 sectors but the Ubuntu-MATE installer will initialize the disk as GPT.

I don't know yet if the EFI partition is needed or that it is just created regardless.

Extra info

I can only conclude that the current Ubuntu-MATE installers probably only support booting from GPT disks and if you want to boot from MBR you probably will need to install the right (non-GPT) grub version manually.

EDIT:Also installed 22.04LTS on this horrible piece of junk:
Notebook: Toshiba Satellite C670D-10F
Processor: AMD E-Series E-350
Graphics Adapter: AMD Radeon HD 6310
Display: 17.30 inch, 16:9, 1600 x 900 pixels
Weight: 2.8kg
Year of manufacture: 2011
Results were identical to the above mentioned ASUS F3T



Your efforts are hugely appreciated.

As you have noticed I am not too familiar with EFI nor GPT.
How did you manage to get this install with a weird grub-core.img partition on your Asus machine? Through the default installer with the 22.04 ISO or thanks to some manual partitioning?

I tried to use exactly the same table (one 1Mb unpartitioned, one 513Mb mounted on /boot/efi and one ext4 for the rest) but that didn't work either. Note that your second partition is named EFI but it is actually a fat32 one according to the "Filesystem" column of your gparted window.

Now, I went back to an older ISO (20.0) and forced the "one big ext4" configuration. Although it warns me that an EFI partition is required and that I do so at my own risk, the installation goes through and I ended up with a bootable system again.

I wanted to be clever and tried to install 22.04 alongside the working 20.0 but there is some repartitioning involved that will probably not make it work.

I am a bit fed up with booting that thing and configuring the installation as I've probably done it more than 30 times now, but would that make sense to try other ISOs between 20.0 and 22.4 ?

1 Like

Or other operating systems, there are many made for older computers that would still work without all the problems. I understand wanting Ubuntu Mate it is a great OS I love, but is it worth the trouble you are experiencing?


Trough the default installer.
I chose the option: "erase the whole disk and install Ubuntu-MATE 22.04"
The installer will then setup the appropriate partitiontable, creates the partitions and format these automatically.

This includes creating and formatting the EFI partition and creating the grub-core.img partition and writing the appropriate (grub) bootloader. Again, this is all done automatically by the installer.

Yes, EFI partitions should always be formatted as fat32, this is part of the design/specification. It won't work if it's not fat32 formatted.


No, not really.
However, if you have 20.04 running ,you can do an in-place upgrade to 22.04 by issuing the following terminalcommand:

sudo do-release-upgrade 

Make sure that you are fully updated before issuing this command.


Thanks to all for the assistance.


An upgrade seems to be the reasonable option indeed.

I chose the option: "erase the whole disk and install Ubuntu-MATE 22.04"
The installer will then setup the appropriate partitiontable, creates the partitions and format these **automatically**.

Well, that didn' work for me. This option lead to two partitions, a small EFI one and a big ext4 one. No magic grub2-core.img on /dev/sda1 and the result fails to boot. Tried a manual grub after that but grub-installer returned an error message.

An up and running system is satisfying enough though and the LTS gives me enough room to play with.


Thank for the link, it's a great resource I wasn't aware of and I really like the search tool.

It's not too many of them distros for old computers though. Only 7 are Debian-based and as you can see I need an active community to assist me with the twists and turns.

Bodhi Linux seemed to fit the bill but it is Ubuntu based and from what I've seen with ubuntu-mate and mint-xfce the latest releases seem to share a common default installer which fails with my setup.

But I've learned a couple of things in the process which is the entire point after all, so I can still call it a win.

1 Like

Hi, @Piko :slight_smile:

To supplement the great answers that @tkn (thom) and @jymm(jim) have already given you in this topic:

First: if you have important information (documents, pictures and/or other personal files) in your Ubuntu MATE 20.04 installation, I suggest that you start by backing up those files (to an external USB connected hard drive, for example), before you attempt an upgrade and/or before you change BIOS settings, in case something goes wrong.

Then, I agree 100% with @tkn's suggestion: if you are booting correctly to Ubuntu MATE 20.04 LTS ("Focal Fossa") in your "Lenovo ThinkCentre Edge 71" tower desktop computer - - then the easiest and safest way to upgrade to Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") seems to be to run the following command in a "MATE Terminal" window in your Ubuntu MATE 20.04 LTS setup:
sudo do-release-upgrade

Having said that, I've found the following "How to boot to Legacy device or system configured with Microsoft Windows 7 or Windows 10 - ThinkPad, ThinkCentre, ThinkStation, ideacentre - Lenovo Support US" article in the Lenovo support web site that seems to be relevant, IF you really wish to set up your BIOS to change the boot mode to the Legacy / CSM (Compatibility Support Module) mode:

In that article, the most relevant section seems to be the following :

" (...) Solution

To boot to Legacy devices or systems configured with Microsoft Windows 7 (32-bit or 64-bit) or Windows 10:

1. Restart the PC and press F1 to enter Setup.
2. For ThinkPad: Navigate to the RESTART menu.
For ThinkCentre and ThinkStation: Navigate to the EXIT menu
3. Select OS Optimized Defaults and change the value to Disabled.
bios settings
4. Select Yes to continue to disable the OS Optimized Defaults.
5. Press F9 to load Setup Defaults.
6. Select Yes to confirm the loading default configuration.
7. Press F10 to save and exit Setup.
8. If necessary, press F12 to access the boot menu and select your boot device."

For easier reference, I'm quoting here the text from the "Item Specific Help" section contained in the right-hand side the screenshot above, regarding the "OS Optimized Defaults" option:

" Item Specific Help
The default value of settings below are changed accordingly.
Select "Enabled" to meet Microsoft (R) Windows 8 (R) Certification Requirement.
Affected settings are CSM Support, UEFI/Legacy Boot, UEFI/Legacy Boot Priority, Secure Boot, Secure Rollback Prevention."

I remind that, to set the boot mode in the BIOS to Legacy / CSM mode, that "OS Optimized Defaults" setting should be set to "Disabled", according to that same Lenovo Support article.

I hope this helps :slight_smile:


Thank you @ricmarques,

I wish I had the "OS Optimized defaults" to disable in the BIOS. Unfortunately, mine seems to be very minimal compared to the screenshots of other Lenovos I see, which confirms that a bios upgrade wouldn't be such a bad idea.

The good thing with this machine is that I have absolutely zilch on it. I am just slightly concerned that I might brick the bios and hence produce a bit more of electronic waste which we already have enough of...