No puedo instalar Wine

Hola, he instalado Wine desde Ubuntu Software, me aparece como instalado, pero al intentar ejecutar un .exe, wine no aparece .

He intentado instalar wine desde el terminal siguiendo los siguientes pasos y tampoco lo he conseguido.

Versión ubuntu 20.04

https://wiki.winhq.org/Ubuntu

[email protected]:~$ sudo apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
winehq-stable : Depende: wine-stable (= 7.0.0.0~focal-1)
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.
[email protected]:~$

He intentado reparar los paquetes rotos siguiendo los pasos siguientes pero no ha funcionado:

Gracias

Tested on UM 20.04

sudo dpkg --add-architecture i386 
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo add-apt-repository 'deb https://dl.winehq.org/wine-builds/ubuntu/ focal main' 
sudo apt update
sudo apt install --install-recommends winehq-stable
wine --version
wine-7.0

Tested on UM 22.04

sudo dpkg --add-architecture i386 
sudo apt update
sudo apt install wine64
wine --version
wine-6.0

Gracias @pavlos_kairis pero continua apareciendo el mismo error

[email protected]Box:~$ sudo apt install --install-recommends winehq-stable
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios aún no se han creado o se
han sacado de «Incoming».
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
winehq-stable : Depende: wine-stable (= 7.0.0.0~focal-1)
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

Toni, please show output of apt policy libc6 libc6:i386

These two libraries should have the exact same version table.

Thanks Pavlos