No software boutique or welcome in 24.04

I've upgraded Ubuntu Mate for several years. Since the option to upgrade from 23.10 to 24.04 has not appeared in my system, I decided to do a fresh install of 24.04. I've tried loading it three times. But it does not have the Welcome or the Software Boutique. Since I can't load my software, I don't know that else may not be working.

I'm a low tech user and just looking for the best option for me:
-Reload 23.10 and wait for a my computer to recognize the 24.04 update?
-Load back to 22.04 which has a longer life cycle remaining than 23.10 and try to upgrade to 24.04 later?
-Try Ubuntu or Ubuntu Cinnamon? Low tech user here, so if this is not a problem that is widespread with fixes coming, I won't be able to fix it with the help of a more knowledgeable user.

1 Like

Did you read Ubuntu MATE 24.04 LTS Release Notes | Ubuntu MATE

You'll note for example

  • Added App Center, that replaces Software Boutique.
  • Retired Ubuntu MATE Welcome; although it is still available for Ubuntu MATE 23.10 and earlier.

and more.


Thanks, I managed to use the release notes to get the App Center installed. I cannot find Bleachbit or GParted there. Am I missing something like the old "install a software center", or are those not available as snaps yet? I can try to download those from their websites, but I like having Canonical adapt them and keep them updated.

1 Like

Hi, @Jim4444 :slight_smile:

According to what I see in the "App Center" in an Ubuntu MATE 24.04 LTS ("Noble Numbat") Virtual Machine, GParted and Bleachbit are available but only as "Debian Packages" and not as "Snap packages". So, when you do a search in "App Center," apparently the "Filter By" dropdown list defaults to "Snap packages" and if you search with that default option for the word gparted you get "No results for "gparted" ":

HOWEVER, if you then change the selected option in the "Filter by" dropdown list from "Snap packages" to "Debian packages":

... THEN, now you get the "GParted Partition Editor" in the search results area, as you can see in the following screenshot:

I hope this helps :slight_smile:


Thanks for the lesson, but there is something wrong in my system. When I change it to Debian, I can start typing and it will keep showing me three possible "snap" options and if I click on one of those, it will take me to install that software. But when I click "see all results...", it tells me "no results found...". No results filtering in Debian, for "gpart", "gparted", "bleach", "bleachbit", "a", "b" and "c". The filter still says Debian, but no results.

24.04 doesn't like my old HP laptop. I reloaded 24.04. The App worked the same as the previous paragraph, "no results...".

Hi again, @Jim4444 :slight_smile:

You wrote:

Actually ... you're right! When I wrote my previous reply, I was using the "App Center" (snap-store) version that came preinstalled with Ubuntu MATE 24.04 LTS (Noble Numbat) that had the correct behavior that I described in that reply of mine, and which is the following version:

Version: 0+git.1419621
Rev: 1124

HOWEVER, after I've written my earlier reply to you, the "App Center", in that Ubuntu MATE 24.04 VM (Virtual Machine) of mine, got automatically updated to the following version:

Version: 0+git.97116aa
Rev: 1134

After that update of "snap-store" happened, I then started having the same incorrect behavior that you're having, @Jim4444 !

Based on this finding, I've opened, a few minutes ago, the following Bug Report in the "Issues" page of the "App Center" Ubuntu Git Hub Repository. Let's see if I get any answers there:


I agree that removing things like the software boutique and welcome makes Ubuntu Mate less user friendly.

The app centre isn't a good replacement Imo.

I liked the idea of a collection of recommended useful software that easy to install for non-tech people.

I Feel like I can't recommend Ubuntu mate to friends and family without teaching them how to use Linux.

1 Like

I believe I now have some good news, @Jim4444 :slight_smile: "d-loose" (Dennis Loose) from Canonical has replied to my Bug Report - "Search with a "Filter by" of "Debian packages" not working in "snap-store" version "0+git.97116aa" Rev. 1134 · Issue #1685 · ubuntu/app-center · GitHub" - confirming that it is indeed a Bug and mentioned that a fix for this Bug is underway:

d-loose commented 13 hours ago:

Thanks for the report - I suspect you see something like this when running snap-store from the terminal:

[ERROR:flutter/runtime/] Unhandled exception:
FormatException: Unknown url type 'vcs-browser'

A fix for this is underway canonical/appstream.dart#30 [ ]

1 Like

I followed the canonical link and it says the issue is "closed". It has not been fixed on my computer. I updated and the App center Debian failed. I reloaded Ubuntu-Mate and it failed. I reloaded Ubuntu-Mate again, without being connected to the internet so I would be using the App center version in the download and App center Debian did not work. Then I connected to the internet and updated and App center Debian failed again. Has anyone been able to find Gparted or Bleachbit in the App center Debian? Maybe it's something with my old HP laptop.

Hi again, @Jim4444 :slight_smile:

As far as I can tell, that bug of "App Center" (which is now the same thing as snap-store) not showing Debian packages, in Ubuntu MATE 24.04 LTS ("Noble Numbat"), even when we change the selected option in the "Filter by " dropdown list from "Snap packages " to "Debian packages", is fixed in the current version of "snap-store" which is 0+git.ec3fa65 (1147)

So, my suggestion is for you to please do the following:

1. - Close the "App Center".

2. - Open a "MATE Terminal" window and, in that "MATE Terminal" window:

2.1. - Run the following command to guarantee that there are no more processes running from "App Center":

killall snap-store

2.2 - Run the following command to see what version of snap-store is currently installed:

snap info snap-store | grep 'installed:'

2.3. - Run the following command to update snap-store to the latest version:

sudo snap refresh snap-store

2.4 - After that previous command execution completes, run the following command to see what version of snap-store got installed after that update:

snap info snap-store | grep 'installed:'

3. - Open the "App Center" by going to the "Ubuntu MATE" menu -> "Administration" -> "App Center".

4. - In the "App Center" window that opens, do a search for gparted in the search bar located at the top. It will probably still show "No results found for "gparted" " as shown in the following screenshot:

Screenshot of App Center search for gparted in Snap packages

5. - In that same window, change the selected option in the "Filter by" dropdown list from "Snap packages " to "Debian packages" as shown in the following screenshot:

Screenshot of App Center search while changing the Filter by option from Snap packages to Debian packages

... THEN, now you should get the "GParted Partition Editor" in the search results area, as shown in the following screenshot:

Screenshot of App Center showing results for gparted when Filter By is set to Debian packages

I hope this helps :slight_smile: Please reply again to this topic to tell us if this solved your problem.


Thanks for those directions. That worked to give me access to the Debian packages. I had success in the terminal, a pleasant surprise.